Jack sees Soundcraft MADI-USB card but Ardour does not

System: Ubuntu 14.04 with Ardour 3.5.308 and QjackCtl installed. Soundcraft Expression digital mixer connected to USB port via MADI-USB card installed in mixer. Soundcraft Channel direct outputs are mapped to MADI-USB channels.

Qjack Interface and Input device are set to Soundcraft MADI-USB COMBO (hw:2). When Qjack is started the Message window says that all inputs and outputs are mapped to system:capture 1-32 and system:playback 1-32.

Then I start Ardour. It still uses the default mic and doesn’t see the USB device. The Audio/Midi setup in Ardour says that Jack is handling that. The Audio Connection manager lists only 2 system inputs.

I’m stuck. Can someone give me a hand?

Got a screenshot of your audio setup dialog? It sounds like you are somehow starting Ardour with wrong settings even after starting Jack, which makes me wonder if you are running Jack as root where Ardour run as a user can’t see it? By the way, which USB-MADI device are you using? I may be interested in it.


running both as a user not root…
mark 3405 5.3 4.1 2139308 334480 ? SLl 21:05 0:05 /usr/lib/ardour
mark 3464 1.1 1.6 914184 130404 ? SLl 21:06 0:00 /usr/bin/qjackc
I don’t think I can upload an image of the setup dialog without putting it on a server somewhere.

After rebooting my system I seem to be able to get Jack to save my configuration settings and use the USB device as the interface and input source. Ardour is now seeing the USB device as the source and I can map capture_1 to Audio 1 input in the Mixer window. I’m still not getting any signal though.The MADI-USB card is made by Soundcraft and fits into their Expression and Performer mixers. Perhaps it doesn’t see a driver it recognizes? I did read a posting on the Harrison Mixbus site about that.

I don't think I can upload an image of the setup dialog without putting it on a server somewhere.

imgur or similar work fine for this.

Ardour doesn’t care about drivers for audio cards, if it is seen by Jack it should be able to be used. If you have it recognizing the card, my next question is if you patch an input to an output, do you hear it again on the console or not? This would help track down if the issue may be a routing thing on the card or not.

A shame it requires one of their mixers, always looking out for good options there.


I tried running it back to an input of the console but that didn’t work. I tried the Latency Measurement Tool in the Audio/Midi dialog and got this message…
“The audio backend has either been shutdown or it disconnected Ardour because Ardour was not fast enough. Try to restart the audio backend and save the session.”

Either there is something wrong with the mixer or I don’t have it set up correctly. It didn’t work on my Mac with Garage Band or Presonus Studio One. I have yet to talk to anyone outside of Soundcraft who has been able to record with it using the MADI-USB card.

Success. I did not read the manual for the MADI-USB card carefully enough. I had mapped input channels 1-1 with the card channels. The first 32 inputs on the card are meant for a stagebox. I needed to map 1-33, 2-34 etc. So now I need to read the Ardour manual CAREFULLY to route the output where I want it to go. Thanks for your replies. I hope this will help someone else.

Did you ever figure this out? I have the same set up and my card is found in Jack but I can’t get access to any of the channels I don’t understand how the routing works. Were you successful?