JACK routing disabled within Ardour (Ubuntu 17.04)

Hello all,

Either I have come across a bug, or I seem to be having some trouble understanding an aspect of the routing system with regards to JACK. For some reason, using the routing system within ardour to make connections between tracks and ports is not working. I can pull up the routing windows, see all of the tracks, see what connections are there, but when I try to make connections in those windows, there is simply no response. I click, see the green dot appear, and when the mouse button lifts, the green dot is gone and no connection is made. Conversely, I can make connections via external managers like Carla, or qjackctl, but the connections made in this way do not persist upon restarting Ardour or rebooting the system. This works fine for small projects, but is not usable for bigger projects with complex routing configurations, or when using large instruments with 32 inputs and outputs etc. I have gone over the documentation and settings many times, only to be frustrated and still unable to fix the problem. My question, is am I missing something in terms of my setup and configuration? Is there some option somewhere that I need to adjust, permissions to set, or is this a straight up bug of some sort? Any info would be greatly appreciated. Thanks!

(Ububtu 17.04 with KXstudio repository enabled, Ardour-KX version 5.11.4, KDE desktop.)

really? no one has any ideas?

Possibly a stupid question, but have you set Ardour to use JACK (and not use ALSA directly)?

You do not have any other rules in place (like jack.plumbing)?

@jrigg - yes, I made certain that jack was set as the sound device. I suppose at this point, maybe I could try running it with alsa through a loopback to jack. lol you just gave me an idea!

@JojanBlome - I am not familiar with jack.plumbing. If it is there, I am not aware. Is that the same or similar to jack_patch running in a non-session? Now that you mention it, I do have non-session manager running. You think that could be a conflict?

I do have non-session manager running. You think that could be a conflict?
NSM takes a snapshot of JACK connections (using jack-patch) when it's shut down and restores the snapshot next time it's started. If you shut NSM down before shutting down Ardour, I would expect it to remember Ardour's JACK connections, but it won't if you shut down Ardour first.

Im afraid that using a routing tool like carla or qjactctl isnt feasible once a project has enough tracks in it… even if it recalls the state. I tried the routing again with no nsm running… same problem it would seem

…am following this thread as I a new user am having issues with getting Jack started when I try I get this error:
D-BUS: JACK server could not be started.


I am afraid that error message is very vague. You’ll want to make sure that all of your jack settings are configured properly to match the characteristics of your sound card. If you have the incorrect number of channels or something like a sample rate that your sound card doesn’t support, you could get this message. Also make sure your username is added to the audio group, as permissions can prevent jack from starting. Finally make sure there is not some other API using your hardware, like pulse audio. If some other API is using that audio card, it will block jack from starting. If you want to use pulse and jack at the same time, you’ll need the pulse-audio jack bridge. Jack is confusing as hell when you first start learning it… but once you get understand whats going on it gets easier. Also, check out the KXstudio apps. They make configuring jack easier in my opinion.

i had problems with ubuntu studio and jack for years; for me (ubuntu studio 16.04) worked perfect installing cadence with kx repo; not forgetting the pulseaudio module jack!! Putting Cadence to start at login and here we go, this solved all my problems; important is configuration of cadence of the audio device u use! But there are a lot of bugs in ubuntu studio 17; i installed a version for exampe, which did NOT have SUSPEND sleeping mode, or it didnt work; also ardour 5.x did not work on ubuntu studio 17 very stable; thats why i used ubuntu studio 14.04 LTS, upgraded it to ubuntu 16. and now im using ardour 4 and everything works perfect!!! Strange thing, but Linux has a lot of bugs also in popular distros …

Thanks…any advice is helpful still not getting it (Ardour) to work…and I am running Studio 16 and Ardour 4 …have done a little investigating and things point to the Behringer UM2 not working? also tried running Ardour without Jack the main issue is that sound card is not being recognised
Bus 002 Device 006: ID 08bb:2902 Texas Instruments PCM2902 Audio Codec
disconnected the UM2 and ran sudo lsusb and the TI was NOT on the list…