JACK protocol mismatch (16 vs 23)

I compiled ardour3 from source, as well as Jack. When I try to start ardour I get the following:

Ardour/GTK 3.0 (built using 3142 and GCC version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)) Copyright (C) 1999-2008 Paul Davis Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker

This is free software, and you are welcome to redistribute it
under certain conditions; see the source for copying conditions.
loading default ui configuration file /usr/local/etc/ardour3/ardour3_ui_default.conf
loading user ui configuration file /root/.ardour3/ardour3_ui.conf
Loading ui configuration file /usr/local/etc/ardour3/ardour3_ui_dark.rc
ardour: [INFO]: Ardour will be limited to 1024 open files
loading system configuration file /usr/local/etc/ardour3/ardour_system.rc
ardour: [INFO]: Using SSE optimized routines
ardour: [INFO]: looking for control protocols in /root/.ardour3/surfaces:/usr/local/lib64/ardour3/surfaces
powermate: Opening of powermate failed - No such file or directory
ardour: [INFO]: Control protocol powermate not usable
ardour: [INFO]: Control protocol Mackie not usable
ardour: [INFO]: Control surface protocol discovered: “Generic MIDI”
JACK tmpdir identified as [/dev/shm]
JACK protocol mismatch (16 vs 23)
cannot complete client connection process
client linked with incompatible libjack version.
could not attach to JACK server

Here’s some more hopefully helpful info:
Soundcard: Echo Digital Audio Corporation Layla24 (snd_layla24)
Kernel: 2.6.22-14-generic
Distribution: Ubuntu 7.10 x86_64
libjack0 and libjack-dev Version 0.103.0-6ubuntu1
Jack jackd 0.110.0 (with alsa support)
Ardour The latest SVN build for version 3.

Thanks for any help, I appreciate it. =)

You probably had JACK already installed. You cannot (without knowing quite a lot about Unix) have two versions of JACK installed at the same time. Go back to your JACK source tree, type “make uninstall”. Then re-run ./configure with --prefix=/usr so that it will overwrite any existing installation. Either that or force removal of the pre-installed version.

Thank you so much Paul… you rock!

That worked! I know it’s not much, but I’m making a $25 donation right now.

Thanks again. =)

Another closely related follow-up question…

I got jack and ardour working, however, now when I try to install any software using Synaptic Package Manager and that software depends on libjack0.100.0-0 or higher, it doesn’t see that I already have it. Is there a way to make Synaptic see that libjack is already there? I tried doing something like, PKG_CONFIG_PATH="$PKG_CONFIG_PATH:/path/to/pkgconfig_for_jack", but that doesn’t seem to work.

Thanks in advance.