Jack: no input but playback ok!

Hi,
I am a Ardour user for 2 years, done some fun stuff, previously everything worked perfectly.
Some time ago, I had to reinstall the whole OS for different reasons.
Now Ardour is working ok for playing, it plays (previously recorded) projects.
But I now have some a serious issue: no input, when connecting a source to some track, from the “capture” channel (either with qjackctl or directly from Ardour).

I think this is mostly a Jack issue/misconfiguration but I have been working on this for several hours, trying out random stuff, and still stuck.

So I shutdown Ardour and focused on Jack.

When Jack is running (started with qjackctl):

  • I connect some audio source on my audio interface
  • I use the “connect” button from qjackctl to connect “capture” to “playback”
    screenshot: https://imgur.com/iHStfhx.png
    => no sound coming from monitor
    (It used to work with my previous install).

So I tried Audacity separatly, to find come clues:

  • when Jack is selected as “host” (preferences->devices): it plays the wave, but nothing gets recorded
  • when ALSA is selected as “host”, no sound is produced when playing (although the Audacity embeded monitor show some signal), but recording works!

Tech details: I use at present a different sound card for recording (Swissonic UA-2x2) and for playing (Intel integrated sound card):

$ cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7120000 irq 128
 1 [UA2X2          ]: USB-Audio - UA-2X2
                      Swissonic UA-2X2 at usb-0000:00:14.0-6, full speed

I tried different settings on the “setup” pane of Qjackctl, but don’t want to mess up things too much…

I checked $ alsamixer, selected my sound card, and checked that capture is not to 0.

Do you think this is an issue with Pulseaudio interfering with Jack?
I read about that, tried the “pasuspender” trick, but no change.

This is really strange, because with my previous OS install, never had such an issue, it just…worked.
What can I try next?

Thanks for your help.

Some additional info:

  • very strange: pavucontrol [screenshot] does not show my Intel sound card, although it appears in /proc/asound/cards (see previous post) ! (and although I do get sound from it, the other interface has no physical audio connection on its outputs)
    Could this be related ?

And it is correctly listed:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: UA2X2 [UA-2X2], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

That is a pulseaudio software volume, unrelated to actual hardware mixer.

try alsamixer (or alsamixergui).

1 Like

Thanks Robin, yes, did try that.
But not sure what you mean by “hardware mixer”?
I hear this as “physical” mixer, seems unrelated here.

a “hardware mixer” in this context is the actual hardware (electronics) inside your audio interface that handles signal mixing and routing within it. alsamixer is the primary tool for manipulating its settings.

1 Like

Thank you Paul, I see.

So: sorry for the noise: problem solved, I don’t know how:

  • The “connect” pane of Qjackctl now shows the additional items: PulseAudio Jack sink in the outputs, and PulseAudio Jack Source in the outputs
  • When connecting system->capture_1 to system->playback_1, I am able to monitor the input audio
  • Consequently, recording with Ardour is fine
  • pavucontrol now shows in the “output devices” tab 3 items: my 2 sound cards and “Jack sink (pulse audio jack sink)”

I really don’t know what happened, probably something I tried that did only take action when a cold reboot occurs. Indeed, I did not reboot every time I tried some different configuration.
Linux audio is pretty much obscure sometimes… Not very fun for non-techies musicians!

But anyhow, great tools, great job, thanks to all that made that possible, keep on the good work!