Jack-keyboard, VMPK not showing up in Ardour


I can’t remember when it last worked,
but now when I try to connect a virtual MIDI keyboard (to play MIDI notes with my laptops’ keyboard like jack-keyboard & VMPK), neither shows up in Ardour.
What I’m trying to do is connect the virtual keyboard to a synthesizer on a MIDI track in Ardour.

I’m running Ardour version 6.9.0 on 64 bit Intel, Fedora Linux. I installed the Fedora Jam ‘spin’ which comes with audio software preinstalled.
If I’m not mistaking I have ‘pipewire-jack-audio-connection-kit’ installed. I don’t know to what degree that could cause issues.

It’s kind of weird, as it has worked before.

I’m sorry that I don’t have so much information to give though.

Regards & thank you in advance,

While I cannot help with the direct issue, Ardour 6 has a built-in virtual keyboard (Ardour Menu > Window > Virtual Keyboard).

Other than that, check that Ardour is using Audio System: JACK (in Ardour Menu > Window > Audio/MIDI Setup), and that other applications are also using Pipewire’s jack emulation.

Perhaps try to make it explicit: pw-jack jack-application-to-run-here, and check if the JACK ports are listed: pw-jack jack_lsp. That may help to investigate the issue.

1 Like

Thank you. The builtin virtual keyboard works.
And I’ve just tried it again, and now ‘jack-keyboard’ seems to work as well.


$ pw-jack vmpk Failure loading Qt5 system translations for "nl_BE" from "/usr/share/qt5/translations" Failure loading VMPK application translations for "nl_BE" from "/usr/bin/../share/vmpk/locale/"

$ pw-jack jack-keyboard Gtk-Message: 22:19:03.878: Failed to load module "pk-gtk-module" lash_open_socket: could not connect to host 'localhost', service '14541' lash_comm_connect_to_server: could not create server connection Connected to JACK server with client name 'LASH_Server' Opened ALSA sequencer with client ID 129 Listening for connections Created project project-1 in directory /home/Lavender-Thief/audio-projects/project-1 Added client 52a57443-c80b-4e65-916e-4078ed40e33c of class jack-keyboard to project project-1 Client 52a57443-c80b-4e65-916e-4078ed40e33c set its name to 'jack-keyboard'

$ `pw-jack jack_lsp /usr/bin/pw-jack: regel 78: exec: jack_lsp: niet gevonden

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.