Jack introducing latency/noise

I am having trouble with Jack introducing what I am assuming is latency noise (clicks) into my tracks. I notice this noise when I am playing using my midi keyboard regardless of which patch I am using. I have been able to overcome that noise by stopping Jack and using alsa instead. When I do that, I do not have any noise in the track.

However, I am continuing to have trouble with Jack introducing noise into my audio tracks, specifically vocals recorded on an SM58 with an xlr to usb cable. Unfortunately, that noise gets recorded onto the audio track and does not go away with playback in alsa.

I am considering a work-around by recording vocals into a different application and them importing that audio file into ardour for mixing and processing. I would love it, though, if I were able to solve this problem and use ardour for both recording and mixing. I would also be happy if I didn’t need to keep switching between Jack and alsa, as that has it’s own issues. Thanks for the help! As a newbie to using a DAW, this forum is indispensable to me!

This is my current set-up:

Operating System: Ubuntu Studio 23.10
KDE Plasma Version: 5.27.8
KDE Frameworks Version: 5.110.0
Qt Version: 5.15.10
Kernel Version: 6.5.0-26-lowlatency (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-4690K CPU @ 3.50GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 650/PCIe/SSE2
Manufacturer: Gigabyte Technology Co., Ltd.
Product Name: Z97X-SLI

Hello, is there any specific reason why you need JACK?

That’s a good question. I am using Jack because it was part of the Ubuntu Studio installation. I wouldn’t mind switching to alsa and not using Jack at all, but alsa is not seeing my microphone. So, I’m not able to use alsa to record audio tracks.

Have you tried selecting the microphone as input in the Audio/MIDI setup dialog, and selecting your other audio interface as the output? Does it really not “see” the microphone at all, or does it just default to your primary audio interface so you assumed that the microphone was no available?

There is an entry in the FAQ about it. The “how-to” is at the very bottom, the rest of the answer is about why using a USB microphone for any kind of high quality recording is a bad idea.
https://ardour.org/faq.html#say-no-to-usb

If you are using a USB microphone and another audio interface at the same time it is probably lack of clock synchronization between the two interfaces (microphone and other).

Noticeably absent from that information is any information about your audio interface(s) or about the jackd or pipewire configuration you are using. I don’t remember if Ubuntu Studio 23.10 uses pipewire-jack or jackd for the JACK server implementation, there are some configuration differences which are important between the two different implementations.

If you are not using a USB microphone with another soundcard like @ccaudle suggested may be the problem, and only using one audio device, you could try disabling pipewire and pulse audio temporarily with the following commands in the terminal :

systemctl --user stop pulseaudio.socket
systemctl --user stop pulseaudio.service

These commands are not permanent, and everything will be restored on reboot. changing ‘stop’ to ‘start’ may work to bring them back on without logging out, but I am uncertain.

Then run Jack with Ardour and see if it happens when recording. Pipewire has caused me a lot of headache, and I have not even tried to use it with Ardour. When using ALSA or JACK (jackd, not jackdmp(Version 2)), I have had a very stable system.

Just curious, what version of JACK are you using ? I had problems with JACK2 that I did not want to take the time to resolve.

1 Like

I believe I have selected the microphone in the Audio/MIDI setup. I have two choices for a USB device, so I select one of them for my headset and the other for my microphone.
AudioMIDISetup

Then, when I go into the input dialogue for my audio track, I only see an option for an external device.
Audio1Input

I’m not sure if my microphone qualifies as a USB microphone because I am using a Shure SM58 with an xlr to USB cord. I don’t know if the USB adapter has its own clock or not. However, I don’t believe that is the issue because the worst noise and distortion I am getting happens in the MIDI track.

I’m not sure which JACK configuration I am using either! I am going to do more research about that. I’m also going to look into using Jackd without Pipewire. Thanks!

I am running JACK2. I discovered the Ubuntu Studio Audio Configuration which allows me to enable and disable Pipewire, but when I disable Pipewire, I seem to be having trouble making connections in Ardour. I’m going to keep playing with it. Thanks!

Hey, thanks for the help! @Schmitty2005 Your comment about Pipewire got me on the right track. I switched to PulseAudio and set my CPU Governor to performance through Studio Controls. It seems to be working with Jack2 and PulseAudio.