Jack doesn't start

When I click on start audio engine, jack fails to start. I created a /et/csecurity/limits.conf file as per the terminal instructions, but it just comes back with the exact same output. Here’s the output:

JACK COMMAND: /usr/bin/jackd -p 128 -R -P 60 -T -d alsa -n 2 -r 48000 -p 1024 -d hw:0,0
jackd 0.118.0
Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O’Quinn, Torben Hohn and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
Please check your /etc/security/limits.conf for the following lines
and correct/add them:

@audio - rtprio 100
@audio - nice -10

After applying these changes, please re-login in order for them to take effect.

You don’t appear to have a sane system configuration. It is very likely that you
encounter xruns. Please apply all the above mentioned changes and start jack again!

Your username is probably not added to the audio group. Open a terminal window and at the command line type:

sudo usermod -a -G audio (username)

where (username) is your username - e.g. the name you login with. Once this is done, log out and back in again (I normally do a complete restart) and you should now have the correct permissions to allow jack to run in realtime

I’m a member of the group. Still no go.

Which os version / kernel ?

uname -svr

Slackware 13.1, 2.6.33.4 kernel

Update: I just wiped the Ardour version I had and installed the latest from source. The problem persists.

You said you created /etc/security/limits.conf.
This probably means that you do not have linux-pam. Install it first.

See http://jackaudio.org/faq

To do anything useful with Jack you need “preempt” or “rt” kernel. That “rt” means “Real Time” i.e. a special patched version of kernel. I have no idea about SlackWare because I have been using Ubuntu Studio and other Ubuntu versions.

I may have to roll my own… but that’s fairly easy to do with Slack.

@ajaaskel: please don’t propagate this rumor. You do NOT need a specially patched version of the kernel to do anything useful with JACK unless you happen to be unlucky with h/w configuration and/or s/w configuration. Modern Linux mainstream kernels are capable of supporting JACK with moderate latency on “sensible” platforms.

Actually, Paul, I can attest to that. After I figured out how to turn off realtime mode I’ve been recording with Ardour all day and had no trouble. I’m not going to bother with it any more unless it becomes an issue. Thanks to everybody who’s responded.

Pauls point was more that you can enable real time in jack without having to have a real time kernel, they are two different types of real time. Unfortunate clash of terminology. Just to clarify.

To clarify chrisg’s statement a bit more, it is not that they are two different types of terminology, it is that the work that used to be only availiable via a patched version from the preemptable realtime project has now mostly been rolled into the mainline kernel and so long as your kernel configuration is sensible, a standard vanilla kernel can handle most realtime activities now. If you need ultra low latency, that is when you should start looking at patching with the current patches from the -rt project but the vast majority of use cases this is not needed. It is only really needed for live usage(Not referring to tracking a live show) to be honest.

  Seablade

Thing is, in order to enable realtime I have to install linux-PAM, and I’d rather not. As long as it’s running fine without realtime then I’ll run it that way.

@2handband: its a MUCH better idea to run JACK in realtime mode. Whether you think its necessary is ultimately up to you.

This post was flagged by the community and is temporarily hidden.

Please don’t resurrect 10 year old threads, just start a new one. Software has changed so much in 10 years that your solution might have nothing to do with the problem described in the original post.

I can see that you are new here so I don’t want your first impression of us to be negative, so I use this opportunity to welcome you to the forums :slight_smile:

1 Like