Jack can't switch to 48khz rate (no voc recording)

I’m using the Edirol UA-25EX soundcard which should allow me to record vocals at a 48000Hz rate. I usually have it set at 96000Hz rate, but when I switch to 48000, restart my computer and start qjackctl, then this happens:

JACK server starting in realtime mode with priority 10
control device hw:1
control device hw:1
Acquire audio card Audio1
creating alsa driver … hw:1|hw:1|512|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:1
Using ALSA driver USB-Audio running on card 1 - EDIROL UA-25EX at usb-0000:00:1d.0-1.4, full speed
configuring for 48000Hz, period = 512 frames (10.7 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 2 periods for playback
ALSA: could not start playback (Broken pipe)
Cannot start driver
JackServer::Start() failed with -1
control device hw:1
Released audio card Audio1
control device hw:1
Failed to start server
15:40:08.051 JACK was stopped with exit status=255.
15:40:10.005 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jack server is not running or cannot be started

I need it to start up at 48000Hz so I can record vocals (or anything from mic inputs on the soundcard). Any and all advice is helpful. Thanks in advance.

Have you changed the sample rate using the switch at the back of the Edirol UA-25?

Do you have an integrated USB2 hub? (Check the terminal outputs of “lspci | grep -i usb” and “lsusb”) If this is the case, the problem might be caused by a bug in the ehci driver that makes impossible the duplex mode in your system. This was solved not long ago and I think it is already in the latests stable versions of the linux kernel (3.0.9 and 3.1.17 attotw). I suggest you should bug your distro maintainers about it. What distro are you using?

In the meantime, you can use the card in capture only mode for recording, then playback only for mixing, etc.

Cheers, Pablo

christophski: Yeah on the back of the soundcard, I switched it to 48khz, but I usually use it in 96khz. I want to record vocals in 48khz.

Pablo, it looks like I have a usb 2.0 hubs. lsusb:

Bus 002 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 004: ID 0582:00e6 Roland Corp.
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’m using Ubuntu 11.04. I’ve recorded vocals at 48khz with this soundcard, but on a different computer using Ubuntu 10.04.

Smeefer: You have several options, for example, you can:

  1. Use the USB card in “capture only” mode. In order to listen to the recorded tracks via the laptop speakers or headphones, you can launch “alsa_out -dhw:ONBOARD_CARD -jonboard &” as a “script to execute after the server starts” in qjackctl, options tab.

Substitute “ONBOARD_CARD” by the name or the number of the integrated audio card. You can see it in the terminal output of “cat /proc/asound/cards”. Better use names (the short name between the square brackets), also in the interface field in qjackctl, as card numbers assigned by alsa can change between reboots (unless you edit alsa-base.conf to avoid it, as for alsa wiki, multiple cards configuration).

  1. Install a newer kernel, with a sane ehci driver. Not in natty repos, nor in any PPA I am aware of, by now.

  2. Wait for precise pangolin or try it in its alpha / beta stage.

  3. Try AVLinux with their latest kernel (3.0.16).

Probably, there are more and saner options, but I don’t know any more at this time.

Cheers, Pablo

Smeefer: So you have changed the sample rate on the device, have you changed it in qjackctl aswell? I have the older UA-25 and haven’t had a problem yet.

christophski: Yes, I have the hardware (UA25EX) and the software (qjackctl) set to 48000Hz sampling rate. I can’t start Jack. On the Jack message panel, it says what I posted in the first message above.

Pablo: Thanks for the help. Seems like it will be easier for me to do vocal recording in windows7 via Ableton. Hopefully one day I will be able to record vocals in ubuntu.

@Smeefer: don’t pin your hopes on Ubuntu, please. Its just one of many varieties of Linux, and there’s absolutely no reason why it (particularly current versions of it) should be your target Linux distribution.

paul: Thanks for the advice. I’ve been using Ubuntu for 5 years now and it’s just the only linux distro that I’m familiar/experienced with. It works well for most things. I guess that’s why I’m still using it as my primary operating system.


For a general desktop OS setup, Ubuntu works fine. However it falls flat on its face in many ways for audio sadly. That isn’t to say it can’t be gotten to work, but that it takes much more work to do so than a distro like AVLinux (Which IIRC is actually based on a version of Ubuntu just all the work is done for you). A perfect example is exactly the bug you are running into which shouldn’t exist for an AV distro(Again not to say it couldn’t but that fixing it would be much higher priority whereas on Ubuntu it is likely a very low priority compared to other things).



I am also an ubuntu user for many years, but the latest and last versions have been nothing but pain configuring it for pro audio, I still use it for my normal desktop use and decided to build my own debian based audio production system in another partition, which is far better because now I can upgrade my ubuntu with more ease without having to go through the whole audio setup again. You might want to check my blog, just read the section “A little bit of boring history and technical explanation” and you’ll see why ubuntu now is not recommended for pro audio.

EDIT: It doesn’t mean that you have to build the whole system like I did, “I just have a hard time taking the easy way”, but like seablade said, try a distro like A/V linux or Dream Studio, both are developed by ardour users and they should work perfectly well.


Blasphemer!! Just Kidding, AV Linux is based on Debian Stable (Squeeze) and Dream Studio is based on Ubuntu…just sayin’

Ahh ok, can’t keep it straight sorry;)

Technically I am on an Ubuntu based distro at the moment myself, it just ripped out most things Ubuntu related from it other than hardware detection:)


Well, If I understood correctly what Clemens Ladisch wrote in the LAU list not long ago [1], the problem is not in ubuntu or in the UA-25EX driver. The problem is (hopefully, was) deeper, in the linux kernel, in the USB2 (ehci) driver. The patch title sent to the linux-usb ml says:

“The current TT scheduling doesn’t allow to play and then record on a
full-speed device connected to a high speed hub”

[1] linuxaudio.org/mailarchive/lau/2011/11/9/185831

Sorry, but I think it is not fair to blame ubuntu for every problem :slight_smile:

Go to an AV district and see if the bug exists in the deployed kernel;) It isn’t Ubuntu’s fault the bug exists in the kernel no, but that the kernel is deployed as default in Ubuntu is. Of course this is only one of many problems on Ubuntu as well:)

This is really difficult. Now I just want to run qjackctl at 48khz because I need to open old Ardour projects and export all the tracks so I can continue to work on them at my (now) regular 96khz, but I still can’t get qjackctl to run at 96khz.

I can use any help I can get, just need all the tracks from 6 of my old projects.

You always have the dummy (=no soundcard) driver. It works for exports but, needless to say, you won’t hear anything. Otherwise, try alsa in “playback only” mode.

Thank you Pablo, the dummy driver worked for what I needed to do.

Hah! AVLinux works like a champ. I can record vocals through my soundcard inputs now. Everything functions good on 96khz and 48khz sampling rates. I still have ubuntu (now 12.04) installed but I’m basically done with it. Thanks for the good advice on installing AVLinux cause it does exactly what I want it to do. We can’t talk about Ardour3 yet, right?