Jack cannot access /dev/dsp0


I’m trying to use Ardour on my laptop, but I can’t even get Jack running. When I launch it, I get the error

OSS: failed to open device /dev/dsp0: oss_driver.c@549, errno=16 cannot start driver

I am running Ubuntu 9.04, with OSS 4.2 (because ALSA won’t work well with my HDA sound card) and I already added myself to the group “audio”.

Do someone have any idea ? I did not find anything on Google…

Thanks !

what type of laptop do you have? I have an MSI A6000 laptop which has HDA sound card in there and ALSA is picking it fine but I am using Ubuntu 9.10.

Have you tried Ubuntu 9.10 or AVLinux 3.0R1 (http://www.bandshed.net/iso/avlinux3r1-20100201-lxde-i386-en.iso)

Hope that helps.

Rony P.

@vlio: you would have to investigate the JACK OSS backend, which is supported by only one developer, and even then only intermittently. There are very, very few users of JACK on Linux who use the OSS backend, and quite a few developers who wish that, on some level, it simply did not exist (I am one of them, even though I entirely understand the reasons for its original creation). I very much doubt that your HDA device cannot be made to work with ALSA, and I suggest you focus on that approach, since you will find many, many more people who have tackled similar issues.

Thanks for your comments.
When I have time I will switch to 9.10 (or more probably 10.4 by then) and try once more to make the whole ALSA/PulseAudio thing work, which will probably happen one day but for now I am pretty sure it won’t work correctly (no sound in headphones, things like that).
I know there are very few people using OSS these days, which is why it’s so hard to find solutions to problems with it, but for my part I am quite satisfied with the way it is working (surely better than PulseAudio last time I tried it)

if you do not need pulseaudio, remove it or install a distro without it.

I already removed it from my Ubuntu to get OSS working :wink:

any reason then why you are using OSS and not ALSA for the sound chip driver ?


See the first post(And subsequent conversation;)


could this help ?