JACK broken after using Audacity


I really didn’t want to ask help for this because I feel so stupid that I keep messing up JACK every other week. It’s sad that the majority of time spent on a small project, or ‘task’ is wasted on getting the software to work. Seriously, I can easily lose a day doing this.

Okay, now that I am done portraying my stupidity, there’s a difference. This time JACK does not even give an error message. There’s just no sound. I didn’t change any parameters as far as I can recall.

Here’s what I did the days between a working and failing JACK:
I tried Audacity for noise filtering. Although playback in Windows is fluent, in Ubuntu it starts with a few seconds of crackling. So I thought changing the ALSA to OSS in options, but then the sound was gone. Changed it back to ALSA, it worked with the crackles again.

Audacity crashed a few times. I don’t know why it behaves crappy on my P4 Ubuntu machine. So I decided to keep working in Ardour without the filtering from Audacity, just to discover I couldn’t get sound anymore!

I tried everything that seemed logical in my eyes. No sound from my Creative SB Live. I must have tried every HW output and input selectable in JACK with a reboot in between. Other JACK apps give no sound anymore either.

Media players, websites, Audacity, Gnome-theme, they all still give me sound.

How can I help you help me?

Entirely random guess… PulseAudio? Usually responsible for anything that goes annoyingly wrong with a previously functioning audio setup (in my experience)

Yea Pulse might be one of the first things I would look at as well, but just in case it isn’t Pulse…

Assuming you are starting Jack with QJackCTL, what exactly does happen, does the graphics look like it is running and you are just getting no sound? If you check the box for verbose messages, can you copy and paste the contents of the ‘messages’ dialog into pastebin.com and give me a link here to look at? If you aren’t starting Jack this way, how exactly are you starting it?


Note: Plot twist in this post.

Normally, I am not starting jack. It starts automatically with Ardour. That’s ideal, because I like the software to do all the technical stuff for me. :wink: So in the same way, I don’t really know how to check what PulseAudio does wrong. Usually, when anything goes wrong, I just reboot and it works again.

For other stuff, I start Jack Control from the Application > Sound & Video menu in Ubuntu 9.10. Everything comes from the repositories, so it is preconfigured to work in a certain way I think.

If I open JACK Control first and then open a project in Ardour, JACK is not running says pretty much nothing. When I quit and reopen JACK, it IS running. So Ardour must still be doing that automatically. However, I do see this message:

I thought Ardour would set the proper rate for the project automatically. Either way, even when there’s a framerate mismatch, I should still hear sound, and I don’t.

As I am writing this post and downloading all sorts of things such as BitMeter, I discovered that my 16 outputs have been replaced by 2 outputs, and these are the front speakers, which are not attached! I’ve been mixing on the rear speaker outputs for tracks that were stereo anyway, but as you can see in the below screenshot, there are only 2 system outputs in stead of 16. I know, my card only has 6 outputs, but somehow in Ardour/JACK there were always 16. My Gnome Audio config is set to and has always been set to SB Live 4.0 output. (Since I usually have only 2 or 4 speakers attached)

(I’m sorry, I cannot make a clickable link here)

Same when opening a 2.0 project, I had it connected over the rear speakers, now it plays on front. But not before displaying the following message:

[ERROR]: AudioEngine: cannot connect 001 001A228E (ardour:001 001A228E) to ardour:master/in 1 (ardour:master/in 1)
[ERROR]: AudioEngine: cannot connect 01/out 1 (ardour:01/out 1) to ardour:master/in 1 (ardour:master/in 1)
[ERROR]: AudioEngine: cannot connect 001 001A228E (ardour:001 001A228E) to ardour:master/in 2 (ardour:master/in 2)
[ERROR]: AudioEngine: cannot connect 01/out 2 (ardour:01/out 2) to ardour:master/in 2 (ardour:master/in 2)


So I have proven that I made a silly mistake and there is audio after all. And the real question should be: Why did my 16 channels turn into 2 channels, how do I get it back, and how can I set the audio engine back to 48 KHz?

@Redsandro: you’ve got some pretty fundamental problems. Its going to be very hard to help you on a web forum. Please get on IRC and ask for help there. See http://ardour.org/support for information on using IRC.

In the end the solution was not as complicated as I thought.

Apparently, Ubuntu has the tendency of swapping sound card names on boot. Since I knew I set them up correctly the first time (and then some), I never came back to think they were reset again so I kept looking for the problem elsewhere.

[22:29] [Redsandro] I’ve got an issue where my 16 system sound channels have been replaced by 2 channels
[22:30] [Redsandro] I started a topic here: http://ardour.org/node/3490#comment-20891
[22:30] [Redsandro] Anybody want to take a look and help me get my problems sorted out?
[22:35] [macinnisrr] Resandro: When you open the setup dialog for qjackctl, and click on “interface” it should give you the option of which card to select. Ubuntu will sometimes rename the cards you’re using on reboot, so that the internal soundcard will be “hw:0” once, and then “hw:1” after you restart (or restart alsa). I would bet this is what’s happening.
[22:36] [macinnisrr] Resandro: The card selection dialog in your screenshot ONLY affects which card pulseaudio is sending output to, not jack.
[22:41] [Redsandro] ah I see it! Interface is greyed out indeed, even though jack is currently not running
[22:42] [Redsandro] And in/out hardware is indeed back on HW:0, though I think I changed this a lot of times
[22:43] [Redsandro] I’ll try switching them both to hw:1 (SBlive) and see what happens

(quoting for users who google here with similar purposes)

[22:46] [macinnisrr] Resandro: There is a workaround for this problem, I’m just looking it up right now. I actually had the very same issue a couple days ago: two soundcards, and manually having to check which one is which before starting.
[22:47] [macinnisrr] Resandro: and you will have to stop and then start jack for these changes to take place.
[22:53] [macinnisrr] Resandro: I found the workaround, but it’s a little complex. Can you open a terminal, type in “lspci -v” (which will list all the pci cards in your system), then look for the two entries that say “Multimedia audio controller” in the first line (these are your soundcards). After that, tell me what each of them says under “Kernel modules:” (the last line), and I can give you the details you’ll need to enter.
[23:01] [Redsandro] macinnisrr: driver EMU10K1_Audigy module snd-emu10k1
[23:06] [macinnisrr] Resandro: the module “snd-emu10k1” is the driver for the SBLive. is there another listing for the internal soundcard?
[23:07] [Redsandro] macinnisrr: Yes, Intel ICH module: snd-intel8x0
[23:09] [macinnisrr] Resandro: perfect! now you’ll have to edit /etc/modprobe.d/alsa-base.conf. To open this file in Gedit, type (at a terminal, or by pressing alt-f2) “gksu gedit /etc/modprobe.d/alsa-base.conf”, and enter your password at the prompt.
[23:10] [macinnisrr] Redsandro: sorry, I just realized I’d been leaving the first d out of your username this whole time.
[23:16] [Redsandro] macinnisrr: I’ve got it open in geany
[23:20] [macinnisrr_] Redsandro: ok, near the bottom of the file you should see a bunch of entries that say things like: options snd-intel8x0m index=-2 options snd-via82xx-modem index=-2 options snd-usb-audio index=-2 options snd-usb-us122l index=-2 options snd-usb-usx2y index=-2 options snd-usb-caiaq index=-2, etc…
[23:24] [macinnisrr_] at the beginning of this section, just after the line that says “#Prevent abnormal drivers from grabbing index 0”, add two lines; one that says “options snd-emu10k1 index=0” (actually I’ve lost the message you wrote with the exact driver name for your SBLive, so change “snd-emu10k1” to whatever that is. Next add a line below saying “options snd-intel8x0 index=1”, (once again, substitute snd-intel8x0 with the actual driver n
[23:26] [macinnisrr_] Redsandro: Once you’ve done that, save the file (you need root access, as I alluded to earlier), and reboot. Now your SBLive should always be hw:0 and your internal card should always be hw:1.
[23:29] [Redsandro] macinnisrr_: Should I remove the previous entries with the same name first?
[23:30] [macinnisrr_] Redsandro: do you mean entries with the same modules? yes. Otherwise no.
[23:42] [Redsandro] [macinnisrr_]: It worked! At least after this boot it did. SBlive is now hw:0
[23:42] [las] Redsandro: you see now why i recommended you get on IRC and not use forums? :slight_smile:

So basically edit your /etc/modprobe.d/alsa-base.conf to set the index of your cards different. Alt+F2 and
gksudo geany /etc/modprobe.d/alsa-base.conf

Here’s mine (only the last part) after the edit, yours will most definitely be different:
# RED Fix audio renaming
options snd-emu10k1 index=0
options snd-intel8x0 index=1
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
#options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

It works, haven’t seen any errors as of yet!