jack and pulseaudio

i upgraded to the last version of ardour 3.05, and i’m using it with ubuntu 14.04. i cannot do my usual live recording because ardour does not seem to see the behringer xenyx 302 usb input, or any other usb input i tried. if i use audacity it immediately gets the inputs from the usb, any kind. but, needless to say, i would really like to go on using ardour that i prefer!
is there a way to make ardour “see” my inputs? is there an EXTRA easy way to make jack and pulse audio work when i need them?

one thing more: i would like to go on working in ubuntu 14.04. i already tried installing ubuntustudio , and had the same problem described above.

the “extra easy” way relies on your linux distribution gettings things right. If they don’t, there is no extra easy way. Many distributions, including Ubuntu, have gotten this stuff wrong for years. I thought that 14.04 had apparently fixed the problems, but it seems not entirely.

But … your problems are most likely coming from the fact that Ardour itself doesn’t show any non-duplex interfaces. It sounds as if you are using Ardour to start JACK - Ardour’s interface for this is deliberately designed to be simplistic and covering only the most common scenarios (i.e. using duplex audio interface). If you want to do more complicated setups, you should use QJackctl or Cadence to configure and start JACK.

thx Paul, so if i use QjJackctl to start jack, which are the settings that i need? i see the duplex thing was already flagged, and chose from the menu my audio usb device as input, but still i ardour i could not get sound. and , can you suggest me a linux distribution more fit to my recording aims? thanks again

AV Linux did it for me. You can live boot it from CD or USB stick to try it out.
Any other Linux distribution designed for audio and video production should be worth a try.
KXstudio and Dream Studio come recommended elsewhere.


Don’t have QJackCTL open in front of me, but look for dropdowns that say Input Device and Output Device (Or Capture device and playback device, something along those lines:) Set them both to your USB device, note that it might be a different ending number for your device in some cases.


In addition to what Seablade said, you should read http://jackaudio.org/faq/multiple_devices.html (and know that you’ll get even better results with zita-a2j and zita-j2a than with alsa_in and alsa_out; and that JACK1 includes the zita clients as internal clients these days, for even less overhead and more convenience).

pulsaudio has always been problematic with jack i cant believe ubuntu still insist on using it and that some apllications require pulseaudio.

there are several much better distrobutions than ubuntu studio.

Av Linux
Kx Studio (which is ubuntu but setup properly for audio work with no pulseaudio)

pulseaudio may not be the problem though, in qjack change the input and output device to your USB interface. If jack is already started , you will need to stop jack change the interface and start it again.

also check your track routing to make sure your cards capture ports are routed to your tracks input

“also check your track routing to make sure your cards capture ports are routed to your tracks input”
that’s always been a cloudy part for me, how do i do that?

Go to window - tracks and buses, in the dialogue you can select your track and check that the input is set to the right input.

i have checkd in tha QJackctrl settings if the audio in and out were set to my device, and they were.
then in Ardour i selected a mono track, and in the tracks and buses window it says: from HARDWARE to capture1 and IN of the selected track. is that the right setting? i don’t know

hi everybody, just a final note to close this thread. i finally was able to get to record audio to ardour, using a behringer xenyx 302 usb, and setting in and out through the behringer that was immediately recognized by my OS (ubuntu). i still experience coflicts between using pulseaudio and jack applications that i overcome restarting the pc. but for now the recording is doable and that was my goal. when i have time i’ll try installing kxstudio instead of ubuntu, cause apparently this kind of conflicts should be solved in a better way. thx to all the answers, and the developers of Ardour.