JACK 0.118.0

I’m trying to install Jack version 0.118.0 on my ubuntu 8.04 LTS.

I have other Jack dependent applications (from synaptic) that prevent me from completely wiping all Jack related packages, so what I do is that I install Jack in /opt with stow to usr/local that way I prevent breaking anything related to Jack, I have done this successfully up to Jack 0.116.2

Now that Jack has this conflicting previous jack installation checkup there is just no way to install Jack anymore.

If I run configure as ./configure --prefix=/opt/Jack-0.118.0 I still get the error message telling me that I have another jack installation, and the message also shows that to override this use --prefix=… and just doesn’t work.

Any ideas to disable this checkup?


@joegiampaoli: you cannot do parallel installs of software like JACK that involve a server and a library that must stay in sync. If you have JACK already installed then you MUST either remove it or overwrite it. In your case, just use --prefix=/usr to overwrite. It will not break things, unless you are on such an old version of a Debian-derived OS that its still suffering from the most braindead packaging mistake ever. I don’t think that is true for Ubuntu 8.04 but if it is, then you can just do a “forced” apt install to revert to the distro version.

Yes, this is what I just dislike so much about the ubuntu developers and their need to make everything so dependent…, makes me feel like rolling my own linux sometimes.

Ok, I’ll just overwrite everything for Jack then and test along.