I've managed to mess up the connections


Today I was working on my first recording project ever, when I accidentally clicked “Disconnect All” in JACK. I have a crapload of tracks, and I tried manually connecting them to master in, then master out to system playback, but it didn’t work. Nothing seems to happen when I play with the settings in Autoconnect either.

Any help would be greatly appreciated.

Hi MattHood,

if I’m getting this right, you used the option in the JACK menu. All you should need to do is to click on “Reconnect to jack” (or similar) in the same JACK menu. Hopefully you haven’t saved since you’ve disconnected everything. If you have, there’s a good chance that you have to reconnect everything manually after you reconnected Ardour to Jack.

Jack is the soundserver, so when the two are disconnected, you cannot connect anything or engage playback.

Hope this help,


Ah, here we have the next screw up. My muscle memory pushed ctrl-s completely against my will as I exited :wink: . I tried manually hooking them up again, and it worked this time.
Thanks for the response though. Have a great day.