Issues with Ardour 8.1 AND new Focusrite


Not feeling as though I’m winning here. Was hoping to go through some tracks again that I made on Ardour 6.x with the new 8.1 on Fedora.

I also bought a new Scarlet 8i6 3rd gen, to replace the 1st gen 6i6 I’ve had for years, as there are some tools to properly set up the new ones on Linux - GitHub - geoffreybennett/alsa-scarlett-gui: alsa-scarlett-gui is a Gtk4 GUI for the ALSA controls presented by the Linux kernel Focusrite Scarlett2 Mixer Driver

I seem to now have two issues.

I tried to playback a project, and the playback was dropping out here and there on 8.1, and the DSP light going red. I tried again on 6.9, still some but I thought maybe less chop.

I swapped back to the 1st gen 6i6, and although the DSP light goes red now and again, no audio drop outs on the older card.

I spotted a video linked elsewhere on this forum which was good learning - Select instance - Invidious

My buffer size is 1024.

A second issue I’ve got, loading the session in Ardour 8.1, on either Scarlet card, the timing has gone all weird, and midi drums (Drumgizmo) are out from the guitars and vocals. If I load the old 6.9 project, its fine.

Has anyone else had issues with newer Scarlet cards?
Has anyone else had issues with timing going from 6.9 > 8.1?

Ardour itself does not know or care about the soundcard.

Ardour just sees an ALSA device (or JACK or pipewire server), so updating 6.9 … 8.1 should have no effect.

Weird okay. Any thoughts about the issue with the drums bring out of sync?

Had this with a few more projects as well trying out moving to 8.1. Something funny is going off and the drums are all out of sync on the new Ardour. The project I started with 8.1 however is fine, so not sure if its something with the import? Are there any fixes around this with 8.2 maybe that I haven’t got as Fedora have not released it yet?

It sounds like an issue converting v6 sessions to v8. Is there a tempo-map in the v6 session, and if so could you provide an example session?

Without knowing the actual cause, I can’t think of any changes 8.1 → 8.2 that would address this.

Is a tempo map where the time signature or BPM changes as the song goes along?

Just had a look at the Hydrogen project, all the parts are 4/4 and 120 BPM.

I could try and send you the project but its a big file of course.

Some of my sessions had midi regions end up in the wrong place in Ardour 7+ if they were locked to bars and beats in 6.9. That bug is still not fixed and might conceivably not actually be dependent on time/tempo changes, despite what the bug reporter said.

Well I missed out Ardour 7 and so I wouldn’t have noticed this until now trying to use 8, so could maybe be the same bug then.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.