Issues downloading and running ardour 5.12.0

I have downloaded (Multiple times BTW) and get it to open but cannot use the program.

Every time I go to create a project Ardour gives an error message… “Loading Error”, “could not create session in folder…” It doesn’t matter if I try and save it to the desktop or a usb or a different folder anywhere.

This is an ongoing issue. I have also reached out to support but I was wondering if anyone had any tips for me. I have really enjoyed using an older version of Ardour and would really like to get this running again.

Out of curiosity, what is your username on your computer?

Seablade

So you can download and install it and start it, but creating, or loading sessions fails. Is that correct?

What reason is mentioned for the failure (after the colon)? Also can you launch Ardour from a terminal, there may be additional information.

A best guess: You’re using Ardour with JACK and jackd doesn’t have realtime permissions: Ardour 5 or later will refuse to use jack without rt permissions.

Yes. I Actually used the terminal to open the .run download from the ardour website.

"could not create session in folder…” is the response I am getting.

I will take a look. Thanks for the insight.

  1. Download the latest release from ardour.org.
  2. Right-click the downloaded file and choose properties.
  3. Click the Permissions tab and check the option “Allow this file to run as a program”.
  4. Close the dialog and double-click the file.
  5. Follow the prompts.

Those are the instructions I’v found on the reference manual. When I follow this process, step 4 opens up the text editor on my comp and it takes a long time to load just to end with an error.

I ran the program thru the terminal with the end result being the same. (not being able to save a project under any folder including desktop or a usb).

There is also a error message regarding my memory limit. Ardour does not have access to all of the memory on my comp.

Also Jack seems to be working fine. Its ardour itself I believe.

Where is this information in the reference manual?

Via email, I sent you a link to http://ardour.org/first_time_linux.html, which was also referenced as a “must-read” on the download page. This document describes how to install Ardour after downloading it from ardour.org.

It may not have been clear, but people were asking you to copy-and-paste the output from Ardour that shows up in the terminal.

This will be easier and more productively dealt with on IRC where we can interact in real time.

Ok. Thanks I will check the email out. I have been thru the terminal with those commands and still end up in the same place.

Here is the link to that information.
http://manual.ardour.org/setting-up-your-system/platform-specifics/ubuntu-linux/

The message may sound misleading. The important part of the “Cannot create…” message is not where but why. Can you copy/paste the full log of message that Ardour prints when you start it from a terminal? That may shed some light.

The most common reason for this is lack of realtime permissions when using JACK ie “ERROR: JACK: Cannot use real-time scheduling (RR/…) permission denied” – without JACK: Ardour/ALSA will only show a warning.
Since you also get a message about Ardour being unable to lock memory this is the most likely cause.

On Debian based systems you can run sudo dpkg-reconfigure -p high jackd2 , enable rt permissions, and re-login. An Arch you can install the “realtime-privileges” config package. The generic description for other distros is: http://jackaudio.org/faq/linux_rt_config.html

dialog from terminal when starting ardour.

bind txt domain [gtk2_ardour5] to /opt/Ardour-5.12.0/share/locale
Ardour5.12.0 (built using 5.12 and GCC version 5.2.1 20150903)
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /opt/Ardour-5.12.0/etc/system_config
ardour: [INFO]: Loading user configuration file /home/uponamountain/.config/ardour5/config
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel® Core™ i5-2400S CPU @ 2.50GHz
ardour: [INFO]: Using SSE optimized routines
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /opt/Ardour-5.12.0/etc/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/uponamountain/.config/ardour5/ui_config
Gtk-Message: Failed to load module “canberra-gtk-module”
Color shuttle bg not found
ardour: [INFO]: Loading color file /opt/Ardour-5.12.0/share/themes/dark-ardour.colors
ardour: [INFO]: Loading ui configuration file /opt/Ardour-5.12.0/etc/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /opt/Ardour-5.12.0/etc/clearlooks.rc
Found nothing along /home/uponamountain/.config/ardour5/templates:/opt/Ardour-5.12.0/share/templates
run dialog

And when starting a new session from the terminal…

~$ Ardour5 -N /path/to/session
bind txt domain [gtk2_ardour5] to /opt/Ardour-5.12.0/share/locale
Ardour5.12.0 (built using 5.12 and GCC version 5.2.1 20150903)
ardour: [INFO]: Your system is configured to limit Ardour to only 4096 open files
ardour: [INFO]: Loading system configuration file /opt/Ardour-5.12.0/etc/system_config
ardour: [INFO]: Loading user configuration file /home/uponamountain/.config/ardour5/config
ardour: [INFO]: CPU vendor: GenuineIntel
ardour: [INFO]: AVX-capable processor
ardour: [INFO]: CPU brand: Intel® Core™ i5-2400S CPU @ 2.50GHz
ardour: [INFO]: Using SSE optimized routines
Cannot xinstall SIGPIPE error handler
ardour: [INFO]: Loading default ui configuration file /opt/Ardour-5.12.0/etc/default_ui_config
ardour: [INFO]: Loading user ui configuration file /home/uponamountain/.config/ardour5/ui_config
Gtk-Message: Failed to load module “canberra-gtk-module”
Color shuttle bg not found
ardour: [INFO]: Loading color file /opt/Ardour-5.12.0/share/themes/dark-ardour.colors
ardour: [INFO]: Loading ui configuration file /opt/Ardour-5.12.0/etc/clearlooks.rc
ardour: [INFO]: Loading ui configuration file /opt/Ardour-5.12.0/etc/clearlooks.rc
Found nothing along /home/uponamountain/.config/ardour5/templates:/opt/Ardour-5.12.0/share/templates
run dialog

I hope that was what you were asking for.

this is from Jack when opened.

17:15:16.831 Statistics reset.

17:15:16.858 ALSA connection change.

17:15:16.973 D-BUS: Service is available (org.jackaudio.service aka jackdbus).

17:15:16.984 D-BUS: SetParameterValue(‘driver:device’, ‘’): Invalid container address ‘driver’:‘device’:’(null)’ supplied to method ‘SetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Cannot connect to server socket err = No such file or directory

Cannot connect to server request channel

jack server is not running or cannot be started

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

Cannot connect to server socket err = No such file or directory

Cannot connect to server request channel

jack server is not running or cannot be started

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock

17:15:17.068 ALSA connection graph change.

Tue Jul 23 17:15:16 2019: ERROR: Invalid container address ‘driver’:‘device’:’(null)’ supplied to method ‘SetParameterValue’.

Tue Jul 23 17:15:18 2019: Saving settings to “/home/uponamountain/.config/jack/conf.xml” …

17:16:26.699 D-BUS: ResetParameterValue(‘driver:channel’): Invalid container address ‘driver’:‘channel’:’(null)’ supplied to method ‘ResetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:26 2019: ERROR: Invalid container address ‘driver’:‘channel’:’(null)’ supplied to method ‘ResetParameterValue’.

17:16:30.628 D-BUS: SetParameterValue(‘driver:duplex’, ‘true’): Invalid container address ‘driver’:‘duplex’:’(null)’ supplied to method ‘SetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:30 2019: ERROR: Invalid container address ‘driver’:‘duplex’:’(null)’ supplied to method ‘SetParameterValue’.

17:16:31.835 D-BUS: SetParameterValue(‘driver:capture’, ‘’): Parameter value type mismatch: was expecting ‘u’, got ‘s’. (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:31 2019: ERROR: Parameter value type mismatch: was expecting ‘u’, got ‘s’

17:16:32.627 D-BUS: SetParameterValue(‘driver:playback’, ‘’): Parameter value type mismatch: was expecting ‘u’, got ‘s’. (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:32 2019: Saving settings to “/home/uponamountain/.config/jack/conf.xml” …

Tue Jul 23 17:16:32 2019: ERROR: Parameter value type mismatch: was expecting ‘u’, got ‘s’

17:16:33.211 D-BUS: ResetParameterValue(‘driver:inchannels’): Invalid container address ‘driver’:‘inchannels’:’(null)’ supplied to method ‘ResetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:33 2019: ERROR: Invalid container address ‘driver’:‘inchannels’:’(null)’ supplied to method ‘ResetParameterValue’.

17:16:34.547 D-BUS: ResetParameterValue(‘driver:outchannels’): Invalid container address ‘driver’:‘outchannels’:’(null)’ supplied to method ‘ResetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:34 2019: ERROR: Invalid container address ‘driver’:‘outchannels’:’(null)’ supplied to method ‘ResetParameterValue’.

17:16:35.381 D-BUS: SetParameterValue(‘driver:dither’, ‘n’): Invalid container address ‘driver’:‘dither’:’(null)’ supplied to method ‘SetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:35 2019: ERROR: Invalid container address ‘driver’:‘dither’:’(null)’ supplied to method ‘SetParameterValue’.

17:16:37.155 D-BUS: ResetParameterValue(‘driver:input-latency’): Invalid container address ‘driver’:‘input-latency’:’(null)’ supplied to method ‘ResetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:37 2019: ERROR: Invalid container address ‘driver’:‘input-latency’:’(null)’ supplied to method ‘ResetParameterValue’.

17:16:41.620 D-BUS: ResetParameterValue(‘driver:output-latency’): Invalid container address ‘driver’:‘output-latency’:’(null)’ supplied to method ‘ResetParameterValue’… (org.jackaudio.Error.InvalidArgs)

Tue Jul 23 17:16:41 2019: ERROR: Invalid container address ‘driver’:‘output-latency’:’(null)’ supplied to method ‘ResetParameterValue’.

Mikael Hartzellmhartzel

2

May 29

The example assumes that you want Ardour to be able to use max 10 GB of memory (memlock). The username in the example is: mika

Nano is a text editor and you save text in it by pressing ctrl + o and enter.
You exit from nano by pressing: ctrl + x

First open a terminal window and then you open config files in the nano editor and edit them.

  • Add the following lines to limits.conf: sudo nano /etc/security/limits.conf
    @audio - rtprio 99
    @audio - memlock 10000000
  • Add the user that is going to be running Ardour to the group: audio
    sudo usermod -a -G audio mika
  • Add the following lines to 99-sysctl.conf: sudo nano /etc/sysctl.d/99-sysctl.conf
    vm.swappiness = 10
    fs.inotify.max_user_watches = 524288
  • Reboot

This has got it running but I am not getting any signal at the moment.