Issue with fonts

Hi, I have an issue with Ardour’s default’s font, which is that they are pixelated and uncomfortable to read,

I wouldn’t say that it is an existential issue, the software does work but it would be a nice improvement
The F.A.Q says that this is not possible, is there a specific reason why ?
I understand the point of not using the System’s default theme, but I don’t see how switching fonts would be an issue (granted you don’t use crazy weird fonts :slight_smile: )
there is a “ui_config” file in ~/.config/ardour5 but changing the fonts mentioned there doesn’t have any effect and the file gets reverted to its original state every time I launch Ardour

I’m kind of a newbie so there might be an obvious reason to Ardour’s use of fonts and/or an obvious reason to why changing the ui_config file has no effect, but I haven’t found any answer so far

(By the way, I have tried to play around with the UI scale slider in the preferences, but it doesn’t make much of a difference)

EDIT: I am running Debian 10 with i3 and have the latest version of Ardour which otherwise runs fine as far as I can tell

Please take a screenshot. Also let us know if you got ardour from or from Debian’s repositories.

This must have been the issue, I rebuilt ardour using the source from your site and it’s solved, sorry for useless post :confused: