Is there a gcc4 version of Ardour 5 ?

I downloaded Ardour 5.0 64 bit today and tried to install it to my Gentoo system and was greeted with a long list of error messages.

It seems Ardour 5 64 bit is a gcc5 binary, is there a gcc4 version available, gentoo still defaults to gcc4 ?

And I answer myself :slight_smile:


  • Operating System = Linux,
  • Architecture = 64 bit
  • Variant = Full version
  • BInary interface = gcc4

Ardour 5.0 for Linux is supposed to include both architectures, and it automatically (tries to) figure out which one is relevant for your system during install.

Please try to run the Ardour 5.0 install again, and email me ( the “long list of error messages”. Thanks.

I tried to download the ready to run 4.7 yesterday and the 5.0 release today. On both I got a “not UTF-8” error. I am a musician, not a programmer, but I will diligently try to do what ever I need to do in order to try out version 5. Thanks.

Sorry, but your description is not even close to precise enough for us to help. The error occured during downloading? After downloading? Before downloading? After installation? When trying to run it?

Please paste the precise error.

when i try to run Ardour 5 i get an error: /opt/Ardour-5.0.0/bin/ardour-5.0.0: /usr/lib/x86_64-linux-gnu/ version `GLIBCXX_3.4.21’ not found (required by /opt/Ardour-5.0.0/lib/

MoosAirStudios: this is a nasty collision between our new Linux packaging system (designed to avoid having to ask you which compiler was used to build your system-provided plugins, which you probably don’t know), and your system. We are still working on fixing it. In about 2 hours from now (08:00 US Eastern (UTC-5)) you can download again and the new installer will either work correctly or can be given the --gcc4 or -gcc5 argument to select one of the possible compiler versions. One of them will work - in your case, probably --gcc4.

We regret this complexity, but it has been forced upon us by the changes in the compiler and its varied adoption by different Linux distributions.