Is Ardour of the Ubuntu Jaunty Repos built with LV2 support?

Can anyone tell me whether the version Ardour from the Jaunty repositories is built with LV2 support? It is version 2.7.1 revision 4296. Is there any way to find out if it was built with the LV2 flag? Or can anyone give me a definitive response?
I just want to make sure before spending more time trying to get LV2 plugins running.
Hope someone knows and can give me an answer…

If you DO have Jaunty installed, why not install the package from repos and test?
And just read the Plugin section in THIS site on how to install some lv2 plugins

From one of the UbuntuStudio (Jaunty) pages


Ardour is a DAW (Digital Audio Workstation) application for advanced audio editing. Ardour’s capabilities include: multichannel recording, non-destructive editing with unlimited undo/redo, full automation support, a powerful mixer, unlimited tracks/busses/plugins, timecode synchronization, anything to anywhere signal routing, support for standard audio file formats (BWF, WAV, WAV64, AIFF, CAF & more), video synchronisation with SMPTE or MTC code via JACK, support for steinberg’s VST plugins as well as linux LADSPA, LV2 plugin standards and hardware control from surfaces like the Mackie Control Universal.’

Well I have tried it using the description in the PlugIn section of this site and couldn’t get it to work. So before spending more time, I wanted to fire a cry of help to more knowledgable users.
I tried copying the plugins to /usr/lib/lv2 but that did not help. I also tried setting the LV2_PATH. Both didn’t work. Is there anything I’m missing?
Maybe someone can help.

Maybe install lv2core package under synaptic?

Well I can’t get it to work and now ventured into trying to compile ardour 2.8 with LV2, as I’m truly at a loss of what may be the problem…
So now I ran right into the next one. I’m trying to build Ardour, as that as already worked once for me in the past. I followed the building instructions from the home page and every thing seemed to be fine. But during the compiling process I get the following error:

In file included from /usr/include/boost/dynamic_bitset.hpp:15,
from libs/ardour/ardour/session.h:32,
from libs/ardour/ardour/audio_diskstream.h:39,
from libs/ardour/
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp: In member function ‘size_t boost::dynamic_bitset<Block, Allocator>::count() const’:
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: ‘mode’ cannot appear in a constant-expression
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: template argument 1 is invalid
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: expected >' before ‘*’ token /usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: expected(’ before ‘*’ token
/usr/include/boost/dynamic_bitset/dynamic_bitset.hpp:1021: error: expected primary-expression before ‘>’ token
scons: *** [libs/ardour/audio_diskstream.os] Error 1
scons: building terminated because of errors.

It seems that it has something to do with Boost library, but I can’t make out what the error may be. Is the version I’m using maybe too new or too old? I’m using the Boost libraries 1.37 of the Ubuntu repositories. I checked online, but can’t find a solution…
Hope somebody can help me on this.

So I searched a little more and found a solution. Seems to be a regression in
A work around patch is found here:
I patched the file and now it is compiling. Let’s see if it runs through…

So for anyone who might care.
With the Ardour 2.7 from the Ubuntu Jaunty Repos I couldn’t get LV2 to work. After compiling version 2.8 it work directly. So either there is something wrong with the version of Ardour 2.7 or it really IS NOT compiled with LV2 support.
I didn’t even have to set the LV2 paths again or anything for Ardour 2.8. It just found the plugins out of the box, whereas the Ubuntu Ardour doesn’t display any of them.
I’ll see tonight whether the plugins actually work like they should…

Stuff works better here.