Is ardour a hog, or is it just me?

on my macbook pro 2.0 ghz dual core 2 GB of ram computer, it runs at 100% all of the time! Also, the buffers are at 90% or higher at least 90% of the time! Is there some setting i screwed up, or is this app just horribly optimized?

thanks for your replies everyone!
I am launching jack through Jack pilot (i know, total n00b, right)
I’ll get back to you mark about the coreaudio problem

Hey Firefly. Here’s what I did on my OSX install. Granted Im running 10.3.9, but here it goes. Had to install X11 since I didn’t do it on install of the OS. then I installed JackOSX. I configured Jack-pilot even before copying over and running Ardour. Then I just copied the files off the Ardour disk image to a foldeer in my apps folder and away I went.

ah… i don’t want to get off os x… i just love the os so much. Also, if coreaudio is as bad as you say, then how has os x become such a widely used os in recording studios?

he didn’t say that coreaudio is bad. he said that the problem was likely coreaudio-related. but, that being said, most recording studios aren’t hailing the virtues of coreaudio. OS X is widely used in recording studios because there are many applications written for it. period. OS 9, which had nothing even remotely resembling coreaudio was also widely used in recording studios. it was because it ran protools and similar apps.

coreaudio is similar in function, but lacking a few features that jack provides (and ardour requires). jack allows for the passing of audio data between applications at a low latency. most pro-audio applications that require this sort of inter-application communication can not get by on coreaudio alone, either. think rewire, etc.

you may not want to give up OS X completely; but, there’s no reason you couldn’t set up your machine to dual-boot both OS X and a linux distribution. you might find that you love linux just as much.

I do use a duel boot… and I prefer os x.

ok… any ideas more specifically?

Mmm… probably there is something wrong with Jack. I use Ardour on Linux so I can’t be very specific about this.

You screwed something up.

Hi !
Running a 26 tracks project in ardour with EQs and comps everywhere on a Macbook Core2Duo 1.83 with 512 MB RAM … FINE.
You should perhaps check your jack settings
How are you launching jack ? with jackosx ? qjackctl ?

The problem is with CoreAudio. I had the same problems, switched over to ubuntustudio, jack and freebob, and it just worked. And worked very, very well.

Your next problem you will run into is probably disk speed in recording. Laptop drives are normally not speedy enough to do the trick. I run a 10000 rpm SATA drive and it gives me wonderful performance. When using a firewire disk and a couple of USB2.0 drives, the drives just simply could NOT keep up. It wasn’t latency, but the inability to sustain the 4.6MB/s 24 changes generates.

I’m using presonus firepods which require no driver under the mac (they run bebob on the firewire).

I’m running a similar setup and I’d love to see your tips and experiences posted on this new thread. Thanks!

Um… thats really obvious and not helpful at all. Of course you would install and configure jack/x11, and copying the application to your harddisk is what you do with every application. really didn’t help at all, sorry. Actually, with that post after it, it may even seem like something resembling spam O_O.