Is anyone still using an Edirol UA-1000?

Hi,

Historically, I’ve been a 2x2 soundcard user and made the switch to use Linux as my only Desktop almost three years ago.

I saw the opportunity to get myself and Edirol-UA1000 practically for free a year from now and I know it’s very old, but I’m happy with the result. Everything works out of the box.

However, it is quite challenging in some aspects. I have never been able to see inputs and outputs on alsamixer (Jack and Ardour seems them fine) and recently I have tried to install pipewire and it’s totally unusable with the Edirol (it is with other sound cards though) to the point that if Pipewire is installed either I run Ardour with ALSA or it crashes.

Are anyone of you still using the old Edirol? Have you find similar problems?

Good morning.

I am not very knowledgeable about Linux Audio, I am a competent musician rather than a technician so please everyone jump in and correct me here.

Manufactured around 2002 ish, it isn’t going to work with pipe wire is my guess .
If Ardour can see it there must be some sort of legacy driver for it, the functionality that you have maybe as good as it gets. As an aside, were you trying to get an older bit of hardware like this working on Windows or a Mac I doubt your experience would be as good?

hope this helps

Alastair

1 Like

I’ve still got my old Edirol UA-1000, and it still works as well as it ever did. I haven’t tried it with Pipewire, though. Using jackd version 0.125.0 (from debian bullseye/stable) here seems fine. If it works with Ardour’s ALSA backend, I’d say there’s probably a Pipewire bug. What actually goes wrong when you try it with Pipewire?

The internal mixer has never been supported by alsamixer, but I’ve never had a need to change the default routing or internal gains; for anything involving overdubs or monitoring I’ve always just used it with a separate mixing desk. There was (once upon a time) a Windows program to adjust the internal mixer, and supposedly once you’ve made changes to the routing with that they’ll stay changed, but I’ve never had to try it.

1 Like

Of course you are both absolutely right.

It is a very old device and I was stunned that worked right of of the box. I always wondered if the fact that I could not access the mixer was a problem I should expect or a problem on my side, but absolutely, in any other OS it is almost an impossible mission even to use it.

Every time I’ve tried pipewire I have made an snapshot of my system before using Timeshift and after checking it doesn’t work, went back to my previous state. With Jack and ALSA it works flawlessly (even with PulseAudio) so, as said, very happy with the whole deployment.

When installing pipewire… there’s no playback, all audio freezes and I can only use it when configuring Ardour to use ALSA. Again I was unsure if that was to be expected or a problem on my configuration. Pipewire returns all sorts of errors being incapable of even contacting the ports.

I agree with both of you and at the moment I’ll stay where I am.

Thanks for commenting.

Edit: As a small comment, for changing the configuration in the card I have a small sandboxed virtual machine with an old Windows version isolated from the Internet and once again, you are correct, once configured, the settings can be saved into the device.

For what is worth and in case it may help someone, I’ve been having some problems with my Bluetooth keyboard losing connectivity in the last weeks and today, that made my think of Pipewire again and decided to test it since I recently upgraded the OS.

I’m currently using Fedora 36 (guess the magic comes from the kernel and of course Pipewire) and… automagically, everything is working now. It’s amazing to have such an old soundcard with plug and play support. I can even manage connections on Helvum without any problem and record in Ardour with around 2ms of latency.

What an amazing time to be a Linux user!