Installation and drivers for RME HDSP AES 32 PCI

Hello,

I’m setting up a system here. I have Linux Mint 19, a i7 motherboard, and a RME HDSP AES 32 PCI card. the lspci command shows me that Linux sees the card at this port:

06:00.0 Multimedia audio controller: Xilinx Corporation RME Hammerfall DSP MADI (rev eb)

Unfortunately, I have no idea how to initialize it or configure it, or if it’s even possible. Does anyone have suggestions?

Thanks!

Look for hdspconf and hdspmixer, part of the alsa-tools-gui package in Debian.

1 Like

sudo apt install alsa-tools-gui installed properly.

hdspconf output:

HDSPConf 1.4 - Copyright © 2003 Thomas Charbonnel thomas@undata.org
This program comes WITH ABSOLUTELY NO WARRANTY
HDSPConf is free software, see the file copying for details

Looking for HDSP cards :
Card 0 : HDA Intel PCH at 0xf7210000 irq 28
Card 1 : HDA NVidia at 0xf7080000 irq 17
No Hammerfall DSP card found.

That’s unfortunate!
I have a Multiface II which works fine, but it’s an old product, no longer available.
I’ve heard RME’s Linux support is not as good as it was.
If nobody else here has a solution, you might have to take it up with RME.

1 Like

I don’t have first hand experience, and I also do not know if it applied to this specific device.

Some HDSP devices require firmware to be loaded to the device on every power cycle. The alsa-firmware-loaders package (debian/ubuntu) includes “hdsploader - firmware loader for the RME Hammerfall DSP cards” for that purpose.

I don’t know where to get the firmware from, but a web-search for “hdsploader” may help.

1 Like

hdsploader gets me this output:

hdsploader - firmware loader for RME Hammerfall DSP cards
Looking for HDSP + Multiface or Digiface cards :
Card 0 : HDA Intel PCH at 0xf7210000 irq 28
Card 1 : HDA NVidia at 0xf7080000 irq 17

:frowning:

hello,
im using a RME RayDat card on my linux mint system. hdspconf also doesnt work for me, im using the amixer command to configure my card. It is not as good as the GUI provided by RME, but at least some settings can be made.
“amixer controls” should show you the settings which you can set. “amixer contents” shows a more detailed version of the settings that can be made (like read or write access, valid parameter values…).
be sure to use the “-c” option, if you have more than one sound card active. you’ll have to use the correct card number after the -c option, otherwise amixer wont show you the correct settings. something like: “amixer -c 1 contents”.
Your card number can be looked up with the “cat /proc/asound/cards” command.
for more information on how to set parameter values look up the man page.

maybe the amixer command works for you too…

1 Like

I can’t activate the card. I can’t see it other than in lspci. amixer has a whole bunch of options and commands, but I can’t get it to see the card; it pulls up everything for my motherboard and video card though.

This is a total guess, but an archived page on RME’s site says an older hardware flash is needed for Linux compatibility (v202 instead of 204). Who knows if that is still the case, but it may be worth a try. It looks like you need a Windows or Mac computer to run the flashing software.

1 Like

Nice catch! I’m going to give this a try!!

It may be worth pointing out that AES is a digital format – it’s the pro version of S/PDIF. Although the breakout cable from the card has XLRs these are digital outputs, each XLR carrying two channels of digital audio.

To use this card you would need another box to turn AES into analogue audio.

1 Like

I’ve already got outboard converters. I’ve got two Lynx Aurora 8’s. If this update doesn’t work, I’m going to get the LT-USB cards and cross my fingers. Thanks.

Tried live install of UbuntuStudio and I’m seeing the same results.

Firmware ver 235

The old firmware loader needs to be executed on WinXP or 2000. I tried XP compatibility mode under Win764 and nothing happens when I run it.

I’ll have to revisit this another day.

Thanks for that tip GuntherT and for drawing my attention to this, z80. I purchased the AES-32 assuming I could run it under Linux when I needed to. I wasn’t aware it didn’t work anymore.

1 Like

Thanks so much for the help everyone! Unbelievably, I spent the whole day yesterday trying to flash the AES 32 card to the old firmware version with no luck. I’m going to try a computer repair shop soon. I don’t have any XP OS systems here.

I just resurrected an old Windows XP machine from 20 years ago. Windows install wizard sees the card, but it won’t install the drivers on RME’s website. I found the old install disk too and no luck. What a mess. This card was working fine 2 years ago and I haven’t touched it or done anything since.

I’m still taking a crack at this. I got the software driver version 2.4.1.0 from 9/22/05 to run on a Windows XP SP2 machine and it seems the card is working fine. The Hammerfall DSP MADI settings say driver version 2.40 from 5/31/05. When trying to update or roll back the firmware, the program runs but the update fails. I’ve got hardware Revision 235.

From what I’ve gathered, on the RME forum and the Wayback Machine, I might need driver version 2.22 because version 2.4 doesn’t work with the 202 flash update tool.

From this post:

Re: MADI Word Clock Output not working properly on Linux?

And thanks for the firmware!

Side note: firmware 202 doesn’t work with the Windows driver v 2.4 that also is on the archive page.

Version 202 works great with my Linux install though. I wasn’t able to update the Alsa-drivers, which would have been the alternative: the system I’m doing this on is a production system.

I did try a newer Alsa version on a different computer. Firmware 203 works with Alsa 1.0.14; I haven’t tried any other firmware/Alsa combinations though. Still, HDSPe MADI might work with newer Linux drivers.

On the Wayback Machine, there is a file called w2madi_22.zip that is probably what we want. Does anyone have any idea where to get it? (http://web.archive.org/web/20050205221451/http://www.rme-audio.de/download/w2madi_22.zip)

On another note, there are different current driver files on rme-usa.com and the rme-audio.com sites. The rme-usa.com files got my card running.

So confusing! I still haven’t quite deciphered all of the file naming schemes or mapped out version progression.

No luck :frowning: I got the old drivers from RME and the w2madi_22.zip file didn’t work. RME says if I can’t flash it backwards, the only solution is to send it back to RME.