...Install the damned thing?

I’m not a COMPLETE Linux newbie - but I only have a VERY basic knowledge of it.
I’ve tried following the steps on the homepage, but I’m just completely lost.

It’s also a bit strange that when I click on “Download the executable file” it comes up with some instructions (that I unfortunately don’t understand) on how to “build from the source code”.

I’m guessing this means you HAVE to get it from the source code.
Are there links to any walkthroughs for n00bs?

Sorry to just barge in and demand answers, but the program just looks so damned sexy. Hehe.
Thanks for any help.

slownewsday, I think if you just keep restarting Ardour you’ll eventually get it up and running.

From what it seems Ardour with Wine-1.1.15 (at least, 0.9.52 don’t exhibit this behaviour and I haven’t really tried this with any other Wine-1 version) crashes on some dlls after writing the .fsi. So the next time Ardour starts it’ll already have that and go on to the next one. Once all fsi’s are written Ardour should start normally.

It’s no guarantee that all VST dlls will work, but many should, see my posts here: http://ardour.org/node/2495

cool. Your last request is beyond ardour’ scope. Talk to the FST author or even wine devs …

you can open a terminal and type


because chances are you never set your environment PATH to include /usr/local/bin (if you don’t understand this sentence, really, never mind at all. If you do, maybe you should include it but that’s only if you are used to install softwares you compile yourself in /usr/local).

so, if you like what you see, make an icon on your panel or desktop that points to it or use Alt+F2, write /use/local/bin/ardour2 in it and fire it up.

HI there, here’s another Linux newbie question. want to get a final clarification. For Ardour 2.8 (on my UbuntuStudio) I did as explained by Godlikecreature, and after sudo, scons came back with “done building targets”. So, I believe its been installed: how do I actually run it?

hi folks:

latest update - vst’s working! i created usr/local/lib/vst using sudo as suggested by Matt, and then copied .dll files into it. i tried a few plugins, and they work fine withing ardour. however, it appears that only a few vsts work, and if there are .dlls of plugins that ardour can’t deal with, ardour doesn’t startup. after i remove the problematic ones (evident when ardour seems to create .fsi versions of dll - any .dll that doesn’t have a corresponding .fsi file is indigestable!).

learning a lot…

any way to make all .dlls work?

so the VST option is ON by default when you compile ardour from source ?? that’s new then.
Anyway, glad it worked for you.

you should read more the documentation lying somewhere in this website or that came with the source code. You would learn about the environment variable regarding your VST directory so ardour can know it during runtime. I believe there are some default paths like /usr/lib/vst or $HOME/vst but I don’t know if ardour relies on them as a last resort. I don’t use VSTs in ardour so I cannot help here.

Okay, so that worked! Except the filename is ardourvst, but no matter.
Now, how do I use vst, in that where do the .dll files go, so that they can be called from within Ardour?

The VST paths are printed in the terminal window when ardour starts, and no, $HOME/vst isn’t included.
You can set the path manually by setting the VST_PATH variable before running Ardour:
export VST_PATH=~/vst ; ardourvst

But terminal says I do not have permission to create ‘vst’ folder in either of those directories. What next?

sudo mkdir -p /usr/local/lib/vst
sudo chmod 777 !$

GodLikeCreature’s howto did not enable VST for compilation so I was suprised you had VST enabled by trying his howto. Now, if you turned it on yourself, that makes more sense :wink:

OK, let’s assume you use bash a shell. To make sure, open a terminal and type:

echo $SHELL

if it returns /bin/bash or something like that, then you do use bash.

In your home directory, there must be some “hidden” files starting with a .
You will probably find some file like .bashrc

Open it and add

export VST_PATH=$HOME/vst

save and type in the same terminal

. $HOME/.bashrc

(advice: copy paste my stuff)

now, make a vst directory

mkdir $HOME/vst

put your dll files in there

you can now start ardoursvt

hi there, thanks for the suggestions. its looking for:

usr/lib/vst, or

neither of which was created. But terminal says I do not have permission to create ‘vst’ folder in either of those directories. What next?

Also, I used the scons vst=yes, and that seemed to have enabled vst throughout.

Ok - I changed my mind… I AM a complete Linux newbie.

What distribution of Linux are you using? The way Linux often works, the developers of an application don’t provide an installable binary because there are so many different distributions. Rather, the packagers for your distribution do that part. So the answer depends on what distro you’re using. In Ubuntu for example, simply go to “Applications > Add/Remove…” and search for Ardour in the package list.

However, before you can run Ardour, there are probably some other details to straighten out, such as your JACK server configuration. Have you done any audio at all yet in Linux?

To install the “damned thing” you download from this site is by building your own executable, that means compiling it for your pc. What you download here (for linux) is just the RAW source, to build it you must install a lot of packages so your computer can build it, if you ae really not up to it, then install the version your linux distro has in its repositories. Still like cbreeze34 asks, what is your linux distro, someone with maybe same linux distro can guide you a bit…

Installing (“compiling”) the source code from this site is almost certainly not what you want to do. If you’re running Ubuntu you can install a pre-compiled .deb file of the newest version of Ardour from www.getdeb.net . Otherwise it depends entirely on what distribution you’re using, and you should be able to install through the package manager on your computer—although it may not be the most up-to-date version.


I am running Ubuntu intrepid and had my share of doubts in the beginning, but to be honest, Ardour was quite easy to install once I completed the easy but tiring process of downloading all dependencies.

Step by step summary of what I did:

1.- Browse this page (http://www.ardour.org/source_downloads) and download the tarball from the link provided.
2.- Save that file and export it to a place that is easy to access (your home folder should do).
3.- Browse this page (http://www.ardour.org/building) and install all libraries (making sure you install the DEV ones as well) required.
4.- from the terminal, access the folder you created on step 2 and simply run the command:


5.- This command will check for dependencies as a first step, so you may find you are still missing something. Once your dependencies are dealt with, it will build the package.
6.- Once building finishes, run the following command:

sudo scons install

7.- That will install the package. Wait until it finishes.
8.- Start the application by running the following command:


9.- That should be it, although I recommend you start JACK first. In fact, you may want to create a shortcut for Ardour that includes starting JACK as a first step.

Good Luck!

JUst to add…if your running a debian based system.Ubuntu,Mepis.etc…and you want to install all the dev packages to build ardour…you can just “apt-get build-dep ardour” and it will install all the packages needed to build ardour.Now this only works if ardour is in the repo already…apt needs to know what is required to build it…if it dosent know anything about the program then it can not install packages for a program it knows nothing about…