./install.sh: Permission denied

I’m on Debian, can’t install Ardour.

Verifying archive integrity... All good. Uncompressing Ardour...... ./Ardour_64bit-4.0.0.run: 1: eval: ./install.sh: Permission denied

You’d better join us on IRC. Nobody else has reported this problem (and we have many installs on Debian)

Right click on the file in the file manager and click 'Properties'. Click the 'Permissions' tab and tick the box that says 'Allow executing file as program'.
Double click the file to execute it.

His problem was more subtle. He had /tmp mounted with “noexec”. The .run script by default unpacks into /tmp, which means that no files there can be executed. Problem solved by adding --target=/some/dir/where/files/can/be/executable or even just --keep (although this leaves the unpacked archive around afterwards).

I am also getting a similar issue. I just got a new machine and when I try to run the install.sh after making it executable, I get an error.
The install.sh is marked as executable in the terminal (ls and it shows green)
I then attempt to run it as root and this appears.

sudo ./install.sh
./install.sh: 25: ./install.sh: /home/darryl/Downloads/Ardour_64bit-3.5.357-dbg/.stage2.run: Permission denied

I’ve tried in my home directory as well.

Clearly I’m doing something wrong.

Any Ideas?

Yes, I am using Ardour 3.5.357



Try making the “.stage2.run” also executable (chmod +x .stage2.run).

This must be a very odd system and against all shell-specs:
http://man.cx/sh section “command_file” says “the file need not be executable”.

PS. why use 3.5.357? If for some reason you can’t use Ardour-4.1, at least use Ardour-3.5.403.
.357 had various major issues (incl possible data-loss) see http://ardour.org/news/3.5.older.html


The .stage2.run was the issue. Much thanks!


For everybody who reads this, please note that we point downloaders at http://ardour.org/first_time_linux.html which completely describes how to install and covers this particular problem, explaining why it exists and what to do. We sort of hoped that more people would actually read it.

For those of you that still encounter this problem might have a light in the dark by the following solution that I used after I too struggled with permission and install issues like that the .run file is opened by the text editor etc. .

First of all, if you are new to Linux and used to Windows you will sooner or later run into that executing a installation file is not working the same way as it does in Windows at all times. I’m still new to Linux but think it has some nice advantages compared to Windows so these things is just to be learnt.

  1. Open a terminal window. (Usually found under “System” in the menu.)

  2. Open the folder with your Ardour installation file. (Usually located under your personal folder “/Home/‘username’/Downloads”. If new to Linux and uses Firefox click on the arrow symbol showing the latest downloads, usually to the right of the address field.

  3. Locate the Ardour file ex. “Ardour_64bit-4.4.0.run”, and right click on the file icon, you should now get a menu.

  4. Select “Properties”. Change the file permissions by tick a box to make it executable.

  5. Now drag the Ardour file icon to the terminal window which now will expand the full location of the downloads folder.

  6. Press enter and follow the instructions. (Usually you would need to enter password for full installation access and chose Y or N to whether you want JACK and its application is to be installed… which I think is a handy thing to have on-board.)

  7. Logg out of the system and then log in again (or re-boot, this is so that JACK permissions for your user account is updated) and…TADAAA! Everything should have worked right out of the box…hopefully.

I hope this walkthru is to be helpful to other frustrated newcomers users out there.

Thank you so much for a affordable and competent DAW that ARDOUR is! :slight_smile: