Input sound is captured but not recorded

I can’t find no suggestions to my problem on the internet, so it’s time to ask here. Ardour seems to be able to capture microphone input, but just doesn’t record it.

My JACK-Ardour connection seems to be good. I am able to see the microphone input in the level monitor on my recording track. I was also able to record sound from my microphone in a simple recording program from ubuntu (11.04). When I import some wav in ardour, I’m also able to playback it, so output sound is OK (I have the same buildin intel HDA device on input and output).

I click the record icon on the audio track, and then the main record button. It’s “recording”, the level monitor is reacting for my talking into the microphone, but there is no waveform appearing on the track, and nothing is recorded.
What could be the problem?


Gotta check the basics first, you did start transport(Hit Play) after you pressed the Rec Button[s] correct? And are any regions created and the waveform just not drawn, or are there no regions created at all?


He is seeing meters jump which means audio is getting into Ardour so his routing in some fashion is correct(Whether it is the correct audio or not is secondary at the moment, once we can figure out why it isn’t even recording THAT audio then getting the correct audio becomes more important;)


Here a screen of the situation:

Audio 1 is armed, the main recording is on. System:capture_1 is connected to the track. When I connected the capture_1 t directly to the playback on JACK, I could hear me talking to the mic. As you can see, the input level monitor (the blue bar) is getting the sound from the mic.

The “simple recording program” is just a package called “Sound recorder” - description: “This package contains a few media utilities for the GNOME desktop”. Probably some default software installed with ubuntu.

The screen shot should also describe the situation for you. The red line showing the current position was going from the begining on that recording, and no waveform was drawn, no region is created. As I hit the stop button, it just stops where it is and nothing changes. No new waveform on the track.

@dojo: i strongly recommend that you get 2.8.12 from and test that.

@LeatusPenguin, @paul
Thank you for your replies. I am already using the 2.8.12 version as it is shown on the screenshot that I have added earlier. I have dowloaded ardour from directly.
I had a clean installation of ubuntu 11.04 and a fresh download of ardour 2.8.12 a couple of days ago.
During that time I have installed some software, that I needed or wanted to check:

  • QJackCtl,
  • Hydrogen drum machine
  • Jack mixer.
    I don’t know If any aditional software could mess the installation (?)

While I am updating some ubuntu packages in hope that it would change something - do you have some other suggestions :)?

You are using the jack transport. Maybe some other app is locking it up? Have you tried with the internal transport?

Ok, I had some updates to install for ubuntu. I’m right after them and started Ardour. One of those updates must have fixed my problem - it started recording all of the sudden. It must have been a problem external to ardour.

Anyway thank you for replies:) and keep your system updated !

I’m so glad to find another person with the same issue as me! This describes exactly the issue I am having. What did you update, or perhaps what version of ubuntu did you update to?

Any leads would be great. thanks!

Hi, i’m having the same problem here. Tried it with Ardour 2.8.12 and also Mixbus 2.0.5. If i choose one of my four inputs as the input of the channel, it doesn’t record. Follow these steps:

  • Choose some input for the channel
  • Channel record armed
  • Main record button armed
  • Press play
  • Doesn’t record anything
  • Press stop --> The transport still goes on, if meanwhile other channels are unmuted, the sound distorts completely.
  • Press stop once again -> Now the transport stops.

Choosing Jack or Internal as main clock didn’t help.

Now the funny thing is, if i choose disconnect for the input of the channel and then connect one of the inputs of the soundcard with the channel input manually using patchage, it records without problems.
Any ideas or solutions ?

also when i press play the clocks won’t work. when i stop the transport, the clock changes to the correct value.