Input/Output Latency and Overall Latency: How much is too much vs. acceptable?

I have an M-Audio Delta 1010 connected to my Ubuntustudio machine here. Currently, I have the Periods/Buffer set to 3, and the Input and Output Latency set to 2. Setting the Periods/Buffer to 3 shows a latency of 32ms, which I think is all right. What I’m trying to do is minimize X-runs, obviously. I’m not running Ardour right now or using the card, just leaving JACK running at idle to see what happens with the X-runs. I started out with no In/Out latency and a P/B of 2, and got 2 or 3 Xruns, so I upped to a P/B of 3 and an In/Out of 1, and got I think 2 xruns. At 3, 2 and 2, I get maybe 1 or 2 xruns after running for maybe an hour while playing web radio and surfing the web. Is this an acceptable value or should I go higher? I just don’t want a ton of latency, because that makes things sort of difficult over time, with the delay and all. I’m just not quite sure what I should be expecting. Any advice?

Also, if it’s relevant, I’m running at 96khz, and 1024 frames/period.


If you don’t use your setup for live performances, then don’t worry too much about latency. Ardour automatically determines latency and adjusts for it, for latency in and out of your delta1010 as well as with software (internal) latency. Lower latency is beneficial for live ‘realtime’ use of such applications. That being said your input/output latency values are passed on to ardour by JACK, so the more accurate they are the more accurate ardour will be in syncing all your audio.

So really, if all you are doing is recording, set you latency up even higher if you want, it shouldn’t matter.
This is what I have been told by developers, somebody feel free to correct me if I’m wrong.

It’s quite unusual that xruns occur without any JACK load at all. Is jackd running in realtime mode? If you install Ubuntustudio and launch qjackctl, realtime is NOT activated by default.

I get virtualy no xruns with 128 frames,44100khz,2 periods on my Delta 44
My .jackdrc:
jackd -R -P80 -u -dalsa -r44100 -p128 -n2 -D -Chw:0 -Phw:0 -m -H -M

Note the “-R” for realtime. I don’t think the input/output latency setting does anything that decreases xruns. I might be wrong, but i think this setting is to make jack applications aware of external gear that introduce latency in your setup.

Frode Haugsgjerd