input levels??

Hi there,

I have a simple question: how do you guys do to adjust hydrogen’s input levels for multiple simultaneous inputs into Ardour.

I am very surprized that this basic feature is lacking in such a good software as Ardour!

Help welcome!

Many thanks!!

You adjust the output levels of Hydrogen.

It isn’t in Ardour because it really isn’t needed. The input levels are set by the interface in most cases, and so long as the interface does not clip, the signal in Ardour will not clip. Likewise so long as you don’t clip the output of another piece of Jack software, you will not clip the input into Ardour.


@windblow: (1) ardour is not limited to interacting with your audio interface. (2) once a signal is in the digital realm, it makes no difference whether you change its level before recording it or afterwards. (3) put them both together, and you’ll see why Ardour no input level control.

Hi again,

Thanks for your quick reply.

The trouble I have in fact is that when I record Hydrogen’s parts separately but at the same time in Ardour, each drum part on a different track, the only control that I have is the general level control in hydrogen. Using the individual controls in Hydrogen (kick, HH, tom, etc.) has absolutely no effect. And it turns out that some output levels are way too high, but I am unable to lower them individually!!

Thanks again for your help and regards.

I haven’t used HG for years but IIRC, there is an option that lets you choose to output pre- or post-fader for individual HG tracks. Look into the HG settings.

Thank you very much thorgal for your help. I tried your suggestion but sadly it did not work out.
For the time being, I managed to control the input levels in Ardour by using an intermediate mixer, Non-Mixer, between Hydrogen and Ardour.
This is not extremely convenient but it works perfectly.

Thanks again.

? that’ s weird. Sounds like a bug in HG to me. Which version of HG do you have ?

I just made a test with the HG kick recorded in ardour.

The first track is pre-fader, the second is post-fader (checkbox in hydrogen audio setting).

You can see that my manual fader action is having an effect :

Hi again Thorgal,

Firstly, thank you very much for your help. I really appreciate!

In fact my version of Hydrogen is the latest one I guess, that is 0.9.4.

Yes, I suppose there’s a kind of bug in there as there is no difference when I choose pre- and post-fader…

I will make another try and let you know.

Many thanks again!

I don’t usually use hydrogen, so for this little test, I downloaded the debian sid package of version 0.9.5-beta1 (see and go to “binaries”).
Could be 0.9.4 is buggy.

I tried it with Hydrogen 0.9.4 (Gentoo) and it worked fine for me. Try double-checking the following:

  1. In HG, under Tools->Preferences->Audio System, make sure audio interface is set to Jack (if set to Auto the Post-fader/Pre-fader option is not selectable) and set Track output to Post-fader.

  2. Make sure “Create per-instrument outputs” option is checked (you should then see all the different HG tracks in list of Jack connections).

  3. After you change the Preferences in HG, re-check the connections between HG and Ardour, as they may have been re-set to some default.

Thanks Buccia,

I think I found the trouble: in fact, I can select the post-fader option in HG, but when I click OK and go back to the settings, pre-fader is selected!! HG refuses to keep the post-fader setting.
I must say that I uses Jack2, which may be the reason of this problem. I 'll do a complete and fresh reinstall of my system to see if things get better then.

I will let you know. Thanks again for helping!!

hey winblow, I have been using jack2 for almost 1.5 year. I very much doubt it is causing the problem you are seeing. If your OS is matching the binaries found under the link I gave you, I suggest you give 0.9.5-beta1 a try, just to be sure.

Hi Thorgal,

I tried HG 0.9.5beta1, with the same result…isn’t it strange!! lol
Whatsmore, I’ve just tried on another computer, but the trouble is still that HG refuses to maintain the post-fader setting.

extra weird!
maybe HG tries to save the new config in some readable only area ?? in which case you will not be able to change anything from whatever config you already have. But yeah, utterly strange!

Hi thorgal

you know what? lol I did a brand new install of Ubuntu 9.10 with Jack 1.9.6 and Hydrogen 0.9.4 and 0.9.5beta successively, as well as an install with Kubuntu 9.10, on two different PCs, and the result is always the same, that is, unable to maintain the “post-fader” setting in HG!!.. My conclusion is that it is probably a bug in Ubuntu but I am surprized that nobody as never been confronted to this issue…
I tried AVlinux live CD and this time all is working well…

Thanks again for your help!