Incomplete ALSA support for Cirrus Logic CS4206 chip?

Hey gang! First a bit about my system. I’m running the 2.6.35-ARCH kernel on my macbook pro 5,5 which has an HDA NVidia soundcard with a Cirrus Logic CS4206 chip. I have my audio playback working through ALSA (arch packages alsa-lib, alsa-oss, alsa-utils, alsa-plugins) and have installed jack2-svn, qjackctl, and ardour3-svn.

My goal for the time being is to be able to track on ardour, recording from my internal mic. (I have an audio interface but no other mic at the moment) I know this is less than ideal but I just want to be able to record so I can start learning ardour while I save for a mic :slight_smile:

My Problem seems to be with ALSA. I can get my jack server up and running, and Ardour recognizes it and makes the connection. (unlocking my memory is something else I need to figure out). Ir have tried every combination of input/out configurations for my master, and initial audio track but I when I do hear input from my mic it always is with the same quirks. There is a large amount of hiss and distortion of with audio, the level meter never changes as if ardour doesn’t think anything audio is playing, and when ardour records this distorted input no waveform is shown but the sounds do playback (and once again no movement of the level meters).

Now this is what my alsamixer looks like with F5 (view all):

It would seem that I have no input device selection abilities in the mixer. I can change the the volume of capture and turn on and off the left and right channels of the capture. (in the screen I understand that only the left channel is on. it just created less distortion this way). But something is obviously wrong somewhere in this chain of processes!

Does anyone have any ideas? Thanks so much for your time!

There is incomplete support for every “Intel HDA compatible” chipset.

If you care about recording audio (and even playing it back) get yourself a real audio interface, and leave that for gamers and desktop sounds. Yes, really. Even if you get it working, its still a poor quality device.

Ok, can I borrow some money?

Seriously though, I know this is a less than ideal setup (as I stated in my original post) and I would welcome any interface suggestion as I do plan on investing in one in the near future. But only when I can afford it, as I have grown rather fond of both eating and sleeping indoors. This is the computer I have so I want to see if I can at least get things working to the point where I can experiment with the DAW software and, most importantly , create music.

While I imagine ‘get a real interface’ was intended to be helpful, it kind of goes without saying that most of these problems can be solved by throwing money at them. My question is; “Can this work? And if so, how?”


There are some extra Kernel config tweaks required for some Cirrus Logic chipsets, I think at some point in time it required non-free firmware or something so many distributions do not enable it by default in their Kernels. AV Linux has it enabled in it’s kernel so you might want to try the LiveDVD and see if it works for you or recompile your Kernel with Cirrus Logic enabled in your Kernel config and see if that helps.

I didn’t intend to belittle the issue(s) you face. I just want to make it very clear that if you goal is actually “most importantly , create music” then the likelihood that you want to put much effort into trying to get your Intel HDA-style device working properly is small. I’ll leave it to others to make practical suggestions should you decide to continue on with trying to use it.

@ ennui

This is a long shot … but what sample rate are you recording at? Does your problem happen at different sample rates, 44.1k, 48k, etc? A lot of cheaper sound cards are stuck at 48k and if for some reason jack is letting you run at a sample rate your card doesn’t support you might get symptoms like you are experiencing. I vaguely recall having a similar issue some years ago.