Impossible to record anything with jack synced


I cannot record anything with for example seq64 plugged to a midi track like samplev1.
each time I start recording there’s a ghost note and when I stop the recording disappear. I don’t keep anything from the recording ?!
I don’t know what to do. It is related to latency ?

Not enough info to help. Start by describing in detail exactly what you did to setup your connections and start recording.

I have the realtime-privileges installed. OK
I’m using a realtime kernel. OK
I tried with 128 of buffer size after a reboot --> the recording worked.
I retry after closing the session --> the bug reappeared.
After that any attempt fail.

Ok but lets start with other info.

  1. What version of Ardour?

  2. What version of Jack?

  3. Have you checked the MIDI output by seq64 to confirm it is correct?

  4. How are you connecting the MIDI to Ardour? This can be key as for instance if you are depending on the autoconnect feature in seq64 it appears there may be an issue with software opened after it (Thus why your reboots of Ardour don’t work).

  5. And related to the above what version of seq64?


  1. I’m using 6.3-2
  2. Jack version 1.9.14-1
    3… the test I’ve made was with hydrogenaudio.
    Sorry, but I can plug any other midi sequencer the same behavior is happening.

well It’s related to my distribution.
It’s working properly on manjaro

no, in fact.
In order to make things work like it does. I just mustn’t use lash. And I restricted the ports to be automatically plugged.

mind telling which seq64 you are using? it sounds very different than the seq24 that I have tried in the past – curious to see what it provides as a music tool…

A quick googling gives 2 seq64 results.
I doubt it’s the Nintendo64 music editor so it’s probably the revamped seq24 here

It’s the same topic…

according to the maintainer this bug has been resolved through another fork called seq66. He has managed to partially fix the issue for seq64 but it still remains a problem.

could be the issue is with seq64 – a variant of bug#206 since you said it works on a first-hit recording but not thereafter on a new session, it could be that the seq64 application is not performing some kind of clean-up correctly. you should try to report this observation on the seq64 issue tracker and maybe the maintainer can fix the code related for the missing events.

the major problem is that it’s the same behavior with also hydrogen.
It’s not isolated to seq64.

It’s my configuration who’s broken I guess.

Which you still have not described.
Much earlier in the thread I made the suggestion:

A day later you replied:

You never mentioned using lash before then. It is not possible to help if you do not inform what software you are using and how it is configured.

hey I’m sorry but I’m french and it’s hard sometimes to be precise from what I’ve got in mind.

what works finally after testing many tests :

the only way to make things work is to start ardour without autoconnecting the master bus.
I must connect the master bus after the launching of ardour.

What I don’t understand is what is happening if the autoconnect happen after launching ardour which is causing the recording issue.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.