Importing wav files not working (from Zoom R-16 )

I have recorded my band using Zoom R-16 recorders but when I try to import the wav files (16 bit, 44100 Hz) into Ardour (v.5, on Ubuntu Studio), Ardour tells me already when I highlight one of the files that it cant use that file.

I really don’t understand what is happening here, as I am pretty certain that Ardour should be able to handle these files? Each one is is about 588 MB, but that shouldn’t be an issue either, I think? Audacity on the same computer can read and play back each file.

Any ideas about what went wrong here is appreciated, thanks :slight_smile:


Ardour does not directly read file, it uses libsndfile for that. There are known issues for files created by the Zoom R-24 and R-8:

Can you try sndfile-info /path/to/the_file_from_the_zoom.wav ? That can indicate if libsndilfe is indeed the issue.

It’s likely only Ubuntu’s version that has this issue.
You could also use the Ardour-binary from That should not affected by this issue.

Thank you for your reply! I tried the sndfile-info command but I got this response:

Command ‘sndfile-info’ not found, but can be installed with:
sudo apt install sndfile-programs

So I tried that and then I got this:

sndfile-info /home/daniel/bas.WAV
Error : Not able to open input file /home/daniel/bas.WAV.
File : /home/daniel/bas.WAV
Length : 588251136
RIFF : 588251128
fmt : 16

  • Format : 0x1 => WAVE_FORMAT_PCM*
  • Channels : 1*
  • Sample Rate : 44100*
  • Block Align : 2*
  • Bit Width : 16*
  • Bytes/sec : 88200*
    LIST : 196556
  • *** Found weird-ass zero marker. Jumping to end of chunk.*
    Request for header allocation of 393112 denined.
  • *** Offset is now : 0x2FFFC*
    **** Unknown chunk marker (230D0000) at position 196604. Exiting parser.*

Error in WAV file. No ‘data’ chunk marker.

I guess that mean that your diagnosis was correct?

Yes. It is a problem with libsndfile version 1.028. Version 1.027 is fine.

You can download Ardour from the ardour site, the binary there has the correct library built-in.
Or maybe you can downgrade your library to 1.027.
Or you can fix your libsndfile library (that’s what I did, but I’m on Fedora). If you want to rebuild your library I can give you the (very trivial) patch.

1 Like

Hi Sciurius! I downloaded the ardour binary yesterday but haven’t reinstalled it yet.

But I would very much like to try your patch for libsndfile first! Thank you :slight_smile:

Here you go…
(On my Fedora build I increased the version of the library to avoid accidental ‘update’ by another wrong version).

I’m curious if this helps. There are still issues with Zoom-R8 files (see linked issue #374).

@sciurius Can your patched libsndfile read the file linked from ?

Nope. That seems to be another libsndfile bug…
I currently do not have the time to further investigate this.