Importing video on Arch Linux

I have been using Ardour for a while now and always had in the back of my mind that I would one day try to use it to track a short film. When I first tried Ardour (prob vers 5) years ago it imported video with no problems at all. Recently when I went to start this project I was unable to import the video. After a little investigation on the forums I found that this had to do with the version of ffmpeg installed with Arch being too late for this version of Ardour. The solution seemed to be installing ardour-video-tools which I did and everything seemed to work fine. The import video dialogue came up as expected and I was able to navigate to and select the video but nothing happened. No video appeared in the timeline. I made sure I had video selected in the timeline. Is there something obvious I’m missing? I understand this won’t be a problem in version 7. Thanks in advance if anyone has any thoughts or suggestions.

I suggest to get the official binary from

Are there problems with the Arch repository version?

So what you are likely dealing with are packaging issues, I can’t say for certain how the Arch package is built but since you already ran into a problem that was fixed because it was running a to new version of a piece of software, it indicates you may run into others. The binary of Ardour distributed from this site is built with specific versions of packages known to work. That is why it is the ‘supported’ version and also why the first step in troubleshooting a problem is to test it with the version here because if it doesn’t happen on the version here it is likely a packaging issue.


hey Seablade.Thanks for your reply.
I did what Robin suggested and found that video import worked straight away. Great! But I came across a different issue. My favourite synth, Vital, doesn’t seem to want to play with Ardour. From reading the Ardour forums and Vital discord chat it seems that it is something to do with libraries that should be statically linked. It worked fine with the Arch distributed Ardour albeit with Vital obtained from the AUR (Arch User Repository). So now I’m stuck with this dilemma. Ardour that I can track films with or Ardour I can use Vital with but not both. Can you or anyone suggest a solution? Cheers

One option is to import the video using the official Ardour binary and then continue with your distro version of Ardour.

The underlying issue with Vital (Not working on Linux: Libraries are not statically linked - Bugs - Vital) has meanwhile been addressed (scroll down to the end of the topic), so upgrading Vital to 1.5.1 (May 2022) is another option.

Yet another alternatively may be to use Vitalium (free/libre fork of Vital).

Thanks Robin for your excellent advice. FYI, I am doing two out of the three things you suggested. I have updated Vital which worked of course but I am also going with both versions of Ardour on my system. There is still so much in the array of plugins in the Arch distro version that I am comfortable with. I will most likely migrate to just using the official binary. And thanks all responsible for this great bit of software. I love it.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.