Importing from ProTools

I have a full length CD of 13 songs that were recorded at a fancy modern studio with Pro Tools. At the time I got all the files on an external hard drive. It is a huge project, with about 40GB of audio data in 6000 .aif files. Now I’d like to remix the whole project with Ardour (actually Mixbus).

I bought AA Translator and used it to import one of the .ptf files that I believe was a session containing all of the songs (sequentially) with only minor mixing applied so far. That was complicated (wine problems, etc.) but got done. The new .ardour file looks fine, though it’s very big ~5MB, and all the audio files got copied to a new directory. Now the problem is opening it with Mixbus.

I quickly learned that Mixbus wasn’t finding the files, so I tried:

  1. Putting them all in a sub-folder called ‘sounds’
  2. Putting them all in a sub-folder called ‘interchange/“session_name”/audiofiles’
  3. Creating a new session with no content, and then replacing the session file and all the audio files

Always when I try to open the session I get first tons of red “missing” files in the regions tab, then a box pops up saying “please wait while mixbus loads visual data”, then it hangs for about 5 minutes and crashes. Usually nothing changes in any of the folders during this, but a very interesting thing happens when I use the ‘sounds’ folder. After the crash all the 6000 .aif files in there are gone and instead there’s about 100 .wav files, some of which are pretty large, but all of which have zero duration if I try to play them. Oh, and the .wav files have names from some of my .aif files. Maybe my system just isn’t powerful enough and it opens as many of the files as it can handle, tries to convert them to .wav, and then crashes? I’m working on a MacBook Pro, not exactly super-computing.

Anyone have any experience like this? Any ideas? Michael (at AA Translator) was very helpful getting the translation done, but isn’t an Ardour expert.


@tate: Assuming you’re a bona-fide Mixbus customer you have the option of trying ArdourXchange if all else fails. The only problem is that you’d need to find someone who could export your session (from Pro Tools) as an AAF file. If you can find someone to do that for the smaller session I’d be happy to try it for you (assuming the AAF file was small enough for you to send to me somehow).

Try the other options too but in the meantime, ask if the original studio can export your sessions in AAF format and let’s see if you can get the smaller one to me somehow. John

I agree with runaway, that the situation with translating ProTools sessions to Ardour is now very good. I have successfully translated and opened a small ‘toy’ session and gotten all the audio placement and fades and etc. right. Apparently the problem that I’m having that I started this thread about is not related to AAT’s translation.

I heartily recommend AAT to anyone so unfortunate to have to work with PT sessions.


With some input from Paul and eliminating reference to PT’s stupid unused ‘fade files’ it seems that we have some very good progress.

We have another AATranslator release planned very soon but in the meantime any AAT users can contact me for an interim update.


Hmm… my suggestion would be to create the session from the PT file via AATranslator, open it up in Ardour and then create a new snapshot. Try to open that snapshot with Mixbus and see what happens. I can tell you that Mixbus will load Ardour files fine, I have been doing this for some time actually, using Ardour to track live and mix in Mixbus.



Thanks for the suggestion. I don’t think my problem is with Mixbus per se (it is just Ardour, after all). I can’t open the session file at all, with Mixbus or Ardour, because the crash comes before it gets far enough to let me do anything at all (like save a snapshot). This dialog box that says it is loading visual data seems to come while the GUI is still starting up.

@tate: i would suggest that you make the session file available via and also use pastebin to show the output of the following command run from within the session folder: ls -lR *

@Paul: I pasted the contents of the session folder (ls -lR *)

But the session file is too large, 4.7MB with their limit at 1MB.

Is there some other way I can get it to you?


@tate: email it to me at (btw, it turns my stomach to see PT render all those fades as distinct audio files :slight_smile:

@tate: another recommendation. although i understand that your eventual goal is to bring the entire CD into ardour/mixbus, i would suggest you try out a MUCH smaller project first, to check for basic issues. I don’t know how long ardour will take to generate peakfiles for that set of audio, but I’m guessing you can enjoy a pretty good meal while it does so.

@tate: a couple of further comments. Ardour doesn’t convert files to different formats unless you import them explicitly. The .wav files are likely related to the new stub files that should exist for each track. The crash during peakfile generation is troubling. Which version of Ardour are you using and on what platform?


I’ll email you the file shortly. I agree about the fade files, and even more so I’m not sure I care for much that PT does.

I don’t have any smaller PT sessions to work with. I think the engineer who did my recording always worked with all the files together. For example if he was going to mix the second song he would do all his work to it while all the other songs were still there in sequence, so when he saved the session as “second song rough mix” or something like that, that session still needs EVERY audio file just to open. I understand why he did that, but I wish he hadn’t.

I did paste just the beginning of the session file too:

I’ll email the whole thing now.



The crash during peakfile generation is troubling. Which version of Ardour are you using and on what platform?

I use a Macbook Pro (intel) and usually use Mixbus. I’m not sure which Ardour version Mixbus is up to, but I also have Ardour 2.8.8 and get precisely the same behavior there.

By the way, I just verified that if I remove all the files from an otherwise working session, Ardour still starts up just fine. It just shows a lot of “missing” regions in the list and the tracks look empty. This is what I guess it should do with my huge translated session file too, if it just can’t find the files. I’m starting to really worry that the session is just too big for my computer. :frowning:


@tate: btw, can you let me know the output of this command on your system: ulimit -n

in addition, open the Console (Applications -> Utilities -> Console), clear it, and start mixbus (or ardour). paste the output shown as the program starts up right here.

@paul: ulimit -n returns 256, and output of console is at



In reference to ulimit -n, don’t forget that we changed that some time ago to remove the file limit on OS X by default(Since he mentioned Mixbus). I remember going through that fun with you to find that problem and testing it to ensure it was gone…

2/9/11 8:29:36 PM [0x0-0x3f03f].org.ardour.Ardour2[441] ardour: [INFO]: Removed open file count limit. Excellent!

Given this it appears to still be working. I am a bit troubled by the port errors and am wondering exactly how many tracks are in this session with so many source files, to see if a port limit may be being reached, or if that is just a character naming problem though, but I am guessing from your earlier comments this is unrelated to the actual crash?



I think, from watching what the engineer was doing, that there are about 40 tracks. I could be wrong as it was a few years ago and I was trying not to be too annoying while watching over his shoulder. Each track then runs the length of the entire CD and may or may not have any audio for a given song (for example there is a track for a shaker, and it is only used on one song). There are tons of punch-ins and retakes and etc., but I think the main reason for so many files is every single fade is an audio file. This engineer always puts a short fade on the beginning and end of every region he’s using before anything else. So for every file that matters in this project, there are at least two more that don’t.



Just did a quick check - there are 96 tracks, 2,998 clips/items/regions and 4,818 files in the ‘Blues DR M1’ PT session

I acquired a small PT session to test my system with. I translated it and copied all the (11) files. I am having trouble getting Ardour to find everything correctly, but no crashes. So I guess the problem is not the translation of my file. Maybe just the size?