Imported audio plays too fast

I exported some audio tracks from garage band. They’re 32 bit, 44.1khz files. My ardour project is also 44.1kz, 32 bit. The imported tracks play too fast, shifting their pitch up about half an octave. Any ideas? I’m using ardour 5.12 on ubuntu 18.04

Sounds like Ardour is not actually running at 44.1kHz.

While Ardour is running, in a terminal window run:

cd /tmp && wget https://community.ardour.org/files/adevices.sh && bash ./adevices.sh

This will not modify your system; it lists all soundcards, their current settings and applications using them, etc. Then copy+paste all the output of that script and paste it here or link to it.

Thanks, this is very helpful. I see that my usb device is reporting 48000. Why then, does ardour show me this image on startup? If my usb audio is running at 48000, how can I change it?

Screenshot from 2020-10-01 16-56-22

========================================
Part I: ALSA
Advanced Linux Sound Architecture Driver Version k5.4.0-48-generic.

Card 0 (PCH):
  * Playback Device 0 (ALC3271 Analog):
    - Subdevice 0 (hw:PCH,0,0):
      closed

  * Playback Device 3 (HDMI 0):
    - Subdevice 0 (hw:PCH,3,0):
      closed

  * Playback Device 7 (HDMI 1):
    - Subdevice 0 (hw:PCH,7,0):
      closed

  * Playback Device 8 (HDMI 2):
    - Subdevice 0 (hw:PCH,8,0):
      closed

  * Playback Device 9 (HDMI 3):
    - Subdevice 0 (hw:PCH,9,0):
      closed

  * Playback Device 10 (HDMI 4):
    - Subdevice 0 (hw:PCH,10,0):
      closed

  * Recording Device 0 (ALC3271 Analog):
    - Subdevice 0 (hw:PCH,0,0):
      closed

Card 1 (Device):
  * Playback Device 0 (USB Audio):
    - Subdevice 0 (hw:Device,0,0):
      used by: jackd (PID 4900)
      access: MMAP_INTERLEAVED
      format: S16_LE
      subformat: STD
      channels: 2
      rate: 48000 (48000/1)
      period_size: 1024
      buffer_size: 2048

  * Recording Device 0 (USB Audio):
    - Subdevice 0 (hw:Device,0,0):
      used by: jackd (PID 4900)
      access: MMAP_INTERLEAVED
      format: S16_LE
      subformat: STD
      channels: 1
      rate: 48000 (48000/1)
      period_size: 1024
      buffer_size: 2048

========================================
Part II: jack processes
 4900 ?        SLsl   0:00 /usr/bin/jackd -T -ndefault -t 200 -p 2048 -R -T -d alsa -n 2 -r 44100 -p 1024 -d hw:Device,0 -X raw

So your soundcard is using a sample-rate of

Even though you asked jackd to start at 44100.

This happens with some onboard soundcards that only support 48kHz (many HDA Intel cards): jackd silently falls back to use 48kHz. What’s worse is that jackd does not inform Ardour (or other jack clients) that this happened.

The solution is to start jackd using 48kHz, re-create the session, and import the file (they will be resampled).

(Or alternatively don’t use JACK, Ardour/ALSA does warn about this mismatch)

The problem is I can’t use my local sound output with ALSA, because it doesn’t work AT ALL, I have a different forum topic about that. I’m only doing things this way because I’m evaluating ardour, since my input hardware doesn’t work with anything but my mac. I would plan to use a real input and output device if I was actually using ardour for production, but I don’t want to purchase a new interface without testing it out.

Thanks a lot for your help!

Oh I see. you’ve forced jack to 16bit stereo to make it work with that onboard soundcard.

You can do that by setting an environment variable for Ardour’s ALSA backend:

ZITA_ALSA_PCMI_DEBUG=768 Ardour6

or if you got ardour from a Linux distribution, lower case ‘a’

ZITA_ALSA_PCMI_DEBUG=768 ardour6

or well, just keep using JACK while evaluating.

I’ve tried starting a project in 48khz and importing my 44.1khz source audio into the system. It says it’s converting the source audio, but it still plays too fast. The pitch is up a few steps above the original.

I’ve done a bit more research and gotten my external firewire device to work, and I still cannot import all audio correctly. I have 44.1kz audio files from garage band, and if I use 44.1 or 48 for the project, they don’t import well. It says that the files are being converted, but they’re still fast during playback. However, if I set my firewire device to 96khz and set the project to 96 khz, the files convert and play back at the right speed.