import video file


#1

Hi,

I have a problem importing video (mp4 or mpeg) in Ardour 5.3 on Windows 8.
When I choose option “Open video” I get Transcode/Import dialog which says that file is not valid video file or an unsupported video codec or format.
I have installed ffmpeg and Quicktime.

What have I done wrong?

Best
Drazen


#2

While I don’t think this is the problem, what is the codec[s] of the video file?

       Seablade

#3

Hi Seablade… in MediaInfo I get this result for video: AVC (High@L4)(CABAC/4Ref Frames)

P.s.
On linux machine everything works fine

Best
Drazen


#4

Ok my money is on something isn’t working right between harvid and ffmpeg, but I am not sure what and it has been long enough since I have had similar problems I couldn’t really give much help on Linux these days easily, much less Windows, sorry.

       Seablade

#5

Ok Seablade… thanks.

Best

Drazen


#6

It’s a long shot but how big is the file? If Windows 8 is 32-bit (and/or Ardour is 32-bit) it’ll have a maximum file size of 4GB - although in practice, anything bigger than 2GB is usually asking for trouble!!

Can you go back to your provider and ask if they can produce a small sample for you? If a small file works but a large one won’t, maybe that’s the problem ?


#7

Hi John E,

file is 1 minute long… about 20 mb… so I think this is not a problem.

Thanks
Drazen


#8

Hi Drazen. 20MB seems easily downloadable and I’d be happy to take a look here and find out what’s going wrong. Can you put it somewhere where I can download it?


#9

Hi John E,

I can put in on upload… say where.

Best
Drazen


#10

If you’ve got a Dropbox account, upload it to Dropbox and then post a link here. In fact, can you maybe upload two video files:- 1) a small file that loads okay for you… and 2) the faulty one. Thanks,


#11

Hi John E,

I dont think that problem is in video file… because I can load it in Ardour win 7 and linux machine… but not on win 8.

Best
Drazen


#12

Can you import any video file on the Windows 8 machine?

         Seablade

#13

Hi Drazen - if other video files load up okay in Win 8 I’m pretty sure this’ll be a timing issue (but I just want to check).


#14

Hi John E and Seablade,

I tried to load two different video files (mp4 format) on win 8 and they do not load… but on win 7 and linux they do.

Best


#15

Drazen Gara wrote:-
" I tried to load two different video files (mp4 format) on win 8 and they do not load… but on win 7 and linux they do. "

My guess is that this is some specific problem on your Windows 8 system (a permissions issue maybe?)

I’ve a feeling Ardour needs to run some 3rd party app to process the video so maybe it’s not launching properly on that particular system? Instead of launching Ardour the normal way, does it help if you right-click on its icon and choose “Run as administrator” ?


#16

Hi John E,

maybe you are right. It might be a permissions issue because I installed Ardour on computer in school where I teach kids how to do sound design for video.
I will ask system aministrator and get back with answer.
Thank you.

Best
Drazen


#17

Hi,

I have investigated problem with Ardour 5.3 on Win 8… but…

when I log in to school computer as an administrator (Win 8 )… and then when I choose option “Open video” Ardour can read video file properties ( lenght, aspect ratio, frame rate…) but when I choose to load video to session… Xjadeo is opened but completely blank… and I can´t see nothing on it.

Does anyone experienced something similar?

Best
Drazen


#18

Are you logged in as the administrator, or did you use ‘Run as Administrator’ to open Ardour under a different user?

         Seablade

#19

Hi seablade,

I tried both scenarios and situation is the same.

Best

Drazen


#20

Nothing in the log window I assume?

Seablade