Import tracks created with input source that gives feedback

When I add tracks with existing audio with Session > Import, they get initialized with an input of system capture, which quickly goes to feedback (I think system capture is an open mic on the laptop I’m using, which picks up the audio from the speakers). The workaround is easy of course - I just quickly turn off the input.

But, how do I prevent this behavior happening by default on import tracks?

https://manual.ardour.org/preferences-and-session-properties/preferences-dialog/

Under Preferences>Signal Flow>Track and Bus Connections:

Uncheck ‘Connect Track Inputs’

I believe there is also a check box for this when creating a session but not sitting in front of Ardour right now to confirm.

      Seablade