Import multiple takes

Hello,

I’m having some issues with importing multiple tracks from multiple takes into a session.
I’ve searched the forum and bug tracker but didn’t find anything recent, only 10+ year old threads. I wanted to post here first to make sure my workflow is correct and I’m not missing anything.

This is using newest Ardour v6, on AVLinux 2020.4.10.

I have 2 folders with each 22 audio files. These are the 2 takes we gonna choose from to use in our mix (nrs. 11 & 13 in screenshots). I want to:

  1. import tracks from take 1 into the session
  2. import tracks from take 2 into the same tracks, as a different layer (viewable in “Stacked” mode)

I created a new session and opened the import audio dialog, with settings:

  • Add files… -> as new tracks
  • Mapping -> one track per file

This works, but when importing the 2nd take is were things seem to go wrong.

Scenario 1
Shift+click to select all tracks (Editor view)
In import dialog, select files from 2nd take, with settings:

  • Add files… -> to selected tracks
  • Mapping -> 1 track / file

I checked the order of the files and they are the exact same as the 1st take.

At first, everything seems OK, the files from 2nd take are a different layer in the existing tracks.
But after a couple tracks, the order of recordings gets screwed up, for example:
Ardour-import-wrong-tracks
Here, Kick drum & Trumpet tracks are put together.

Scenario 2
Shift+click to select all tracks (Editor view)
In import dialog, and select files from 2nd take, with settings:

  • Add files… -> to selected tracks
  • Mapping -> sequence

This puts all audio files to the first track, and not the selected ones:

Also, in both scenarios, the sources from 2nd take are shown as duplicates in the “Sources” tab:
Ardour-import-duplicate-sources

Is there something wrong with my workflow, should I look at playlists instead of layers, or is it a know bug… Any hints & tips welcome :slight_smile:

Still hoping somebody can help me with this. I’ve dragged the regions to their correct tracks but would be nice if it did so automatically. I’ve made a short clip showing the steps here

TIA.

TL;DR:
How can I
a) import multiple polyphonic (or stereo) .wav-files at once, one track per channel, as a sequence and/or
b) add (one or several) polyphonic .wav-files to existing tracks?


I am currently struggling with a similar problem as BartVaes:
I have multiple polyphonic (4- or 6-channel) .wav-files that represent several takes or parts of a classical piece, recorded with several mics (with a MixPre-6 II, which unfortunately does only work as a 2x2 interface on Linux, so I record to SD-Card.) Now, I want to import the files into Ardour, one track per channel, all .wav-files in a sequence, i.e. one file (take) after the other (or stacked). I have tried several ways and met several problems:

  1. Import all files at once and select Add files: “as new tracks” and mapping: “sequence”.
    This imports all channels into a single polyphonic track.
    Then, I tried to to turn the regions into mono-tracks via the context menu. However, this did not have any effect, irrespective of doing this per region or for several regions at once, and if doing it from the editor view or from the regions list. --> No success this way.

EDIT:
Apparently, the turn-to-mono bug should already be fixed: https://tracker.ardour.org/view.php?id=8228, so I’ll just wait until it is updated in my repo.

  1. Next, I tried to first add only the first file, which puts each channel into a track, as desired. Then, I select all the created tracks and put the play-head at the end of the first region in order to import the subsequent file(s)/track(s) at the play head into the selected tracks. However, the option to add to selected tracks does not appear, apparently, because it is only available for mono-files (which ends to be my current workaround, see below). --> Also no success this way.

  2. Next, I tried to import only into the regions list, one region per channel and hoped to move the regions manually into the tracks later. However, I can only move one region/channel at a time, which effectively destroys the sync between the channels when moving them individually to the respective tracks. --> Also no success.

Additionally (a BUG?), I cannot increase the width of the sources column showing the imported file/region names in the sources tab, making it impossible to select the right regions if the file-names are too long.

  1. I tried to import one file at once similar to 2., but as new tracks (as the same-tracks option was not available) and at the play head, one track per channel. Then, I intended to manually move the newly imported regions from the temporary new track up into the respective tracks of the previous file with middle click (i.e. time-locked) and deleting these now empty tracks afterwards and repeat this for every take. In Ardour 5, this partly worked: I could only move one region at once, not multiple regions to multiple tracks. However, after updating to Ardour 6.0.0, I am currently unable to move a region to any other track, also not with left click! --> Is there some new setting, that prevents moving regions between tracks, which I did not find? --> My previous work-around now also does not work anymore.

EDIT2:
Strangely (after closing and re-opening Ardour several times? No idea why …) moving (also multiple) regions between tracks works again flawlessly! --> Workaround 4 works, hurrah!

  1. Finally, I found a new, rather tedious workaround: First, import all files to region-list, one track per file. Then, import the same files again (now the one copied into the interchange-folder of the project and split as one file per channel) and import them to the selected tracks, which is now available, again one (previous) file (now multiple mono-files) at once. Of course, each time I have to un-select “copy files into project”, otherwise I would duplicate them. --> OK, with this I can at least start working with one of the greatest, smoothest, professional and stable open-source programs I know of and love, but it is quite a stony way to arrive there, especially with lots of takes/files per project …

As this seems such a basic task to me, I could well imagine that I just overlooked the very simple way to do this. It would be really great, if I could get a hint here. Otherwise, maybe one of the problems in my work-arounds can be solved with the right settings/key-combinations/… and ultimately it would be of course great to have this workflow supported natively (if it indeed is not yet.)
THANKS!! (Also, BTW, for this great software and the continuous effort that is going into it since many years!)

I’ve found myself in the same position and, because time was short, my own workaround was to process the files via the free SoundDevices Wave Agent software (works in Linux too via wine-staging) before importing into Ardour. I’m also quite certain that SoX can perform the same actions if you don’t mind the command line. BTW, I, too, am using the MixPre6-II. It’s a shame that the data recorded on the SD card cannot be recorded as anything but a polywav. Apparently the musician plugin allows for individual files per channel. As far as I remember the Zoom equivalents allow for both out of the box…

To further add to the mix…In my particular case, I’d like to be able to import the first two tracks into a stereo track (main stereo pair) and then various mono tracks (spots).

OK, my workaround in 5. also does not work due to the same problem already reported in the original post by BartVaes: The file-(i.e. channel-)track mapping is inconsistent (random?) when importing into selected tracks: In my case, the 2nd and 3rd channel are put into the 3rd and 2nd track, respectively. Together with the current (new in Ardour 6) inability to move regions between tracks effectively renders also workaround 5 unusable and in effect, I am currently not able in any way to work in Ardour! :frowning: :frowning:

Additionally, I also noted that importing the same files again duplicates them in the sources list even when un-checking “copy files into project”. Probably expected and only a side-effect of this (not working) work-around …

Thanks for this hint, @bachstudies! What exactly did you do in SoundDevices Wave Agent? Split the polyphonic .wav-files into separate mono-files? That would be a fine solution (for the duplicate entries in the sources list), if the import would respect the file-name order (see my reply above and the original post by @BartVaes) …

I do various types of splitting. I take my first two channels and create an interleaved stereo file and then the rest (if any) are either a secondary stereo pair or a series of mono spots. Wave Agent is quick and I’ve just built it into my workflow…It would be wonderful if there was a clean way to do this in Ardour (I’m sure there’s a way!).

AFAIK, Ardour would respect the filename order…

Yes, that would be convenient; my solution is to add a group for the stereo-pair during mixing (not editing). (BTW, nested/multiple groups would be really usefull for this scenario!)

Even better, flexibility wise: Is there a way to turn multiple tracks into a single polyphonic/stereo track? (I mean, in Ardour ;))

In Wave Agent? I believe the answer is yes…

In Ardour, I’ve not really had to do that for anything I do. Like I said, I’d be really surprised if there wasn’t a way to do the importing cleanly. In my experience the first two channels of the polywav mapped onto the two pins of the stereo track but I might be misremembering. I suspect out of caution I ran everything through Wave Agent :wink:

Sadly no, that is one of those things that seems easy until you get really into the weeds of how to implement it. Which track is left, or right, or what is the order in polyphonic to start with. If plugins exist on multiple tracks, how are they handled, etc.

It can probably be done it just requires a lot more thought than is obvious.

   Seablade

It should. But look here:
image
On the left is the first imported single polyphonic file. Right of it is the next file, imported after having split it into several mono-files using a first import (to region-list). This is the problem of the original post.

1 Like

Thanks! Anyway, this is a “nice-to-have” feature, I think our core problem here is more serious: How to get multiple multi-channel files (or groups of mono-files) into Ardour in the right/consistent order of channels/files?

I am looking around in Mantis, I swear there was an issue on this, but I can’t find it now. I would suggest going ahead and posting an issue in Mantis (tracker.ardour.org) to get the file ordering fixed. It has a technical reason why it happens that has to be worked around, that may be harder to do than it appears.

  Seablade

Might it have something to do with the ordering as presented in the operating system’s selection dialog? I’ve run into this type of issue on every OS I’ve used including on Windows needing to “reverse” select a directory of files for it to process in the correct order. I have to say I’ve not noticed this bug in my own work with Ardour/Mixbus but I’m often only working with a single long polywav from a live concert recording.

Yes, that’s a part of the story.

The other part of the story is coming up with some heuristic for knowing how the names of similarly named files connect them together. To a human, it may be obvious that “Voices-1.wav” and “Voices-2.wav” have some relationship (even if it is not entirely clear what it is). To a computer, without a heuristic in the code, they are not related in any way other sharing the first 7 characters of their filenames.

1 Like

So are we saying that Ardour could not default to placing MixPreCelloSoloAll1-002%98 after MixPreCelloSoloAll1-002%97 in @jeythekey’s example via simple alpha-numeric ordering as you might see it in a file browser? Likewise, if you are asking to place files sequentially on the same track, again it seems like Ardour should default to importing in alpha-numeric order. I’m doubly puzzled because I feel like I would have seen this happening in my own workflow before now…

Surely alpha-numeric ordering isn’t the same as needing a heuristic? I.e. if you know what you are importing and only select those files, I assume Ardour should import them in order horizontally or synced vertically based on channel/track distribution choice?

We treat foo%N.{wav,aiff,whatever} specially for one reason and one reason only: ProTools does the same.

But as far as I remember, we do this only to identify groups of file that should be collapsed into a single track (i.e. N mono files -> 1 N channel track).

I agree with @bachstudies that I think the first step would be simple alphanumeric ordering in the same way most file browsers do. That means that yes 05 - SomeTrack.wav would come before AnotherTrack01.wav, but I think that would be fine and expected given that 99.9% of software would work the exact same. No need to overthink in this case I believe.

Is it perfect? Nope. Is it better than currently? I would argue yes.

  Seablade
1 Like

But this shouldn’t even come into play then if the user has said to create a new track for each channel, or each file correct?

  Seablade

Waoh, thanks for the prompt reactions and the lively discussion, just great!

As I encountered several, possibly unrelated problems (bugs??): Should I create several issues, one for each problem (bold in my first 2 posts)? Or should we discuss all the issues first here in order to discriminate real bugs from missing knowledge on my side (e.g. how to move regions between tracks in Ardour 6)?

The import-ordering issue seems to already be identified, so I’ll start with that one in the tracker. But what about native support for polyphonic wav-file-import? Should this be a separate issue? I could imagine that it would be rather simple, once the file-ordering is fixed: Just chain the splitting-step (of import to region list) with the import to single/selected tracks and iterate over this for every selected file (if as sequence is selected).