import multiple files to one track

the title says it almost all…

is there a way to import multiple wavs to one track, one after the other? i can only find:
import each file to new track, or import to regions list.
but from the regions list i also can’t select multiple files and move them to one track.

thanks for help

@lokki: in the import dialog, there is an option in the bottom “Mapping” selector for “sequence files”. This is what you want. but unfortunately, it has been broken for quite some time. I may try to fix it before releasing 2.8.8.

@ paul: thanks! this would make PT sessions importing a lot easier. (recording with many takes in one session)

@lokki: this has just been fixed in svn (rev 6729) and will appear in 2.8.8

thanks, that’s fantastic news. it’s great to see that one comment from a user can have such an impact!

ardour is great.

@lokki: a further comment: in fixing this issue, i realized that there is no way to bring N files into 1 track and obey timestamps in the files. Since this seems to me to be the most common likely case for this kind of operation, I’ll be adding a way to get this behaviour too, soon.

so what does it do now? just aligning the file1 after the file2 and then file3, i assume. that’s more than fine already. i agree that adding timestamp “enslavement” would be the way to go in the end.

@lokki: yes, the files are just arranged one right after the other at present.


i successfully compiled rev. 6742 and was able to import the files in sequence mode, great!!!

for your info, it’s a pro tools session with a 24 channel recording. there are 76 takes total, that makes 1824 files.

a few things are popping up:

  1. ardour tells me there are too many files open, so i can’t import all the files (can be worked around by splitting the huge session into two or three smaller ones). i deselected “copy files to session” since i don’t have enough space on my drive to double all the files. could this error be eliminated if i would copy all files to the session? the error appears at the 22nd track, approx 1600 files.

  2. it would be great if the option for sequence files would stay for further importing steps, so that i don’t have to select it for every track again. this is just personal preference though. but since “copy files to session” is remembered as well it would make sense imho.

  3. the killer feature for me would be if there were more sorting options in the import dialog. in particular, pro tools saves stereo-files as file1-l.wav file1-r.wav. so if i sort by name, the stereofiles can’t be easily imported, i have to select every second one. i’m not sure how to implement this in an intelligent way though. maybe adding a filter, name contains…(can be worked around by renaming the files before importing)

these are just some observations i made, i am more than happy already!

thanks so much!!

i was wrong about the session: it’s only 16 channel. and it stops at the 14th channel import with the too many files open error, so at about 1000 files.

when i start ardour in a terminal i can see this:

ardour: [INFO]: Ardour will be limited to 1024 open files

perhaps that is the problem you are having.



The number of open files by a process is limited by a system setting, I can’t remember which one off hand, but I know on OS X we can programmaticly reset this, not sure about on Linux, but you can set it in your system config.


i guess so. that would make sense. actually i had something like this in mind, i think there is an option to to change this behaviour either in ardour itself or at compile time.

thanks seablade for the hint…

google is your friend: