I'm lost with solo and mute. Not working as expected.

Please look at these screenshots first : http://imgur.com/a/j8DAf

I’m confused, when/how do these green circled (as opposed to fully green) buttons appear ?
The expected behaviour of the solo function is modified : even though the tracks do not share being in the same group if I click on solo, every green circled tracks/busses will go solo. And sometimes I cannot even mute the ones I don’t want to ear. Sorry if it’s not clear but I’m really lost and I can’t seem to find any details in the manual.

the outlined buttons indicate that the track/bus is “soloed” because something downstream of it has been explicitly soloed. consider a bunch of tracks routed through a bus (e.g. a group). solo the bus … the tracks must not be muted. the outlined button indicates this status.

it is much better to discuss this sort of stuff on IRC where we can interact in realtime instead via a slow medium like a web forum. the support page (link at top of the page) has information on how to get onto IRC.

There’s obviously something I don’t understand because I have two identical situations : 2 different instruments, each of them having several tracks/busses routed to a higherlevel-bus, nothing special. However, with instrument#1 I have outlined solo buttons on every track/busses but not on instrument#2. Of course, there may be some details that I am oblivious of that make the difference between these two instruments.

"the outlined buttons indicate that the track/bus is “soloed” " : it is not actually soloed, it’s only soloed if I click on the button and make it fully green. I’m not sure what you exactly meant.

sorry, i cannot discuss this on a web forum.

Yep, that’s definitely not easy to explain it here. Thanks nonetheless :slight_smile:

Is it correct to say that if there is nothing explicitly soloed (red solo button at the top next to the clock is not blinking), no channel supposed to be soloed implicitly. That means no outlined solo buttons when the main solo button at the top is not blinking?

If I do observe this, would that be a bug that I should report?

yes. and this bug has been seen recently. we do not know what causes it. i do need to add a workaround to fix the situation when it arises, which will be in the next release.

Is it correct to say that if there is nothing explicitly soloed (red solo button at the top next to the clock is not blinking)

In my particular case, there is indeed nothing that is explicitely soloed (no blinking red solo button).

Yeah, this is hitting me too. The closest I’ve got to a workaround is deactivating the track.

In my case, I can tell you when it started: I picked the permasoloed tracks (each mono standard audio tracks) as sole inputs to a new stereo track to make a stereo dumpdown. I recorded it, and things seemed okay. I set up a second track to do the same for two other mono tracks. I forgot to turn off track record on the first stereo track, and it started recording to both new stereo tracks (as it should’ve). So I hit stop and UNDO.

This is when weird things happened. Undo got rid of both new very short recording regions. But it also deleted the previous stereo region I had recorded correctly from the playlist. I found the region still present in the regions list and dragged it back over to its proper stereo track, and saved. Thinking I’d fatfingered something, I went to this first stereo track again to disconnect the two mono track inputs to it.

Ardour crashed and Jack registered two bus errors.

Now those two mono tracks are permasoloed.

I have had continuous problems with track routing (permamuted and/or permasoloed tracks) since moving to 3.5-357-gce4d125. I’ve been blaming plugins but I’m starting not to be so sure. This new project has nearly no plugins in it at all - a few fast lookahead limiters (put in specifically for this dub-to-stereo operation) and that’s all.

I can zip up a copy of this project if you have any interest in that.