I need a hand with configuring my machine


I’ve been trying to do some recording with ardour, but I’m not being able to achieve the desired latency while monitoring my instruments.

Here is my current software/hardware combo:

Intel core 2 quad Q9400 (2.66Gz)
4GB ram
7200rmp hard drive
Focusrite Scarlett Solo (2 generation)

I’m running a Ubuntu Studio with Ardour 5.3.4

My current situation is:
Everything is working almost fine.
When using sampling rate of 96kHz, 256 frames/period and 2 period/buffer, I’m able to use guitarix with only a few failures here and there, but if I try to record with ardour it start failing like crazy.
I decided to increase latency.
With 48kHz, 512 frames/period and 3 period/buffer, the amount of xrun that appeared while recording decreased a bit, but they were still present.
I tried increasing f/p to 1024, but I still have the occasional xrun.

Can anyone help me figure out what I’m doing wrong, or if maybe my computer is just not good enough to achieve low latency recordings?

Thanks in advance

Your description hints that powersaving could be the issue: guitarix needs lots of CPU and keeps the CPU frequency up and/or prevents the system from entering some power-saving mode; while Ardour mostly idles. Check CPU frequency scaling (software/applet) and maybe even some related BIOS options (disable C1E halt states or EIST).

USB soundcards at that low latency are going to be problematic on most systems, though. Usually you’ll need a realtime-kernel (preemp_rt) and rtirq to get USB soundcards running reliably (x-run free) at 256fpp or below. Preferably the USB soundcard is also on its own bus (lsusb --tree), try a few different USB ports. Some further hints: https://www.linuxmusicians.com/viewtopic.php?f=47&t=10707

Raw CPU power is usually the least concern: http://manual.ardour.org/setting-up-your-system/the-right-computer-system-for-digital-audio/

Thanks for the reply!

I’ll go check how the frequency scaling is doing, then those BIOS options
The kernel that comes with Ubuntu Studio is not the realtime one, but it is tweaked to achieve low latency, maybe I’ll have to try a realtime one.
It is good to know that CPU power isn’t really a concern.

So! I installed the cpufreq monitor, and realize I’m having some frequency changes all over the place. Thankfully, the app already comes with options to leave the CPU frequency maxed. Once I done that, I’m having 96kHz, 256fpp and 2ppb (5.33ms) with quite the stability. In a new project I’m barely having any Xruns (really really rare).

So far, this really solved my issue.
Thanks a lot!

All that with a stock kernel? Thats quite nice!
May I ask why the new sound interface promise such low latencies? Does it uses a different input (like firewire or thunderbird)?

@animah: try replacing your current kernel with realtime or lowlatency one. This could get you totally rid of xruns.