I have been using ardour for a year or two, and ive always had this problem but never worried much about it until now

I seem to have issues regarding the differences in audio quality between the recorded audio, and the recorded/saved/stored audio. Basically, live playback of my guitar, even with effects, sounds much more full,cleaner, better, compared to the sound i get when i play something recorded. Basically, while recording and playing/listening to what i play live as i record, everything sounds great/perfect/clean/full, compared to the playback. Any idea what might be the issue? both audio playback of a recording, and live, have the same volume/gain.

This is a mysterious issue. The obvious explanation would be that when recording, the live input reaches your speakers/headphones via two different paths: Once though Ardour, once via the soundcard’s direct monitoring.
“Louder is better” and a short delay between the two path can also add some flavor.

Can you describe your setup? Which soundcard are you using? What is the complete signal path from guitar to your ear? What settings do you use in Ardour > Window > Audio/MIDI Setup?

Also try the following:

  • Create a new empty Ardour session.
    – Do you hear your guitar though headphones already?
  • Add a Mono Track (the guitar – 1st input – should be auto-connected to that track)
  • Record Arm the track
    – Does the sound change when Rec-arm changes monitoring from Disk → In

Posting some screenshots (mixer window, etc) may also help to try to track this down.

hey, Sorry for the late reply.

So basically my setup is a Tascasm US-144mkII. Running through ASIO, basically having both the input and output as the audio interface. Both live and recorded audio come out of the interface(as in, when I’m playing i hear it through the interface live, and when i play a recording i hear it through it too). the playback of the recording, even when exported, sounds extremely dull/empty/muffled. There are no effects, just a simple E and C chord badly played haha.

When creating the new empty track, I couldn’t automatically already hear the guitar. I had to add the guitar track, and then for me to be able to hear it, I had to arm the track(press the recording button on the track.)

There is no change in sound when individually/specifically clicking on “IN” monitor input while playing.

here is a picture of the steps I too, my set up 1




clips of how it sounds in flac, and wav format

don’t use audio interface’s instrument input.
if you dont want recording mic front of cab,
line level input without audio interface’s gain is best.
caution,
us-144’s xlr input automatically connect to internal mic-pre. it’s not for you.
just use trs input jack from ‘line-drive pedal out or external preamp’s line level out’
banlanced or unbalanced - it’s not big deal.

it’s not ardour’s sound quality issue.

hey, it seems like you know whats going on, but I honestly don’t get it haha. So I am not using XLR, I am using the “Mic Line” with the TRS inputs, left channel for my guitar, and right channel for my bass.

What do you exactly mean by this:
“use trs input jack from ‘line-drive pedal out or external preamp’s line level out”?

with direct input from guitar or bass to audio interface,
your audio interface have to amplify your instrument signal - sound quality can not be accepted. ← now

just use preamp (so many ways) to ‘pre - amp’ - your signal should be line level - before connect audio interface.

find out about signal impedence of

  • microphone signal
  • instrument signal
  • line level signal

BAsically, you are telling me that I should use the right channel, on Guitar/instrument mode, and not mess with the line knob. So when connecting to my audio interface, I should go from my guitar or bass, to a pre-amp, to then the interface.

could you give me an example of somethign i could use to preamp my signal?

i have been looking into this, would a direct box solve my problem?

I’m curious about your recording sample rates, periods, etc. In the screenshot, I can see you’re recording at 44.1, with only 1 Ms of latency. That makes me think your giving the computer really low frames, sample rates and periods. And recording at 44.1 you’re starting at the CD quality that is usually exported to once your done with the mixing and mastering process.

I’ve never strayed far beyond the recommended rates i found here:

https://wiki.linuxaudio.org/wiki/list_of_jack_frame_period_settings_ideal_for_usb_interface

And my plan had always been to record at 48, and export to 44.1 at the end (i don’t work with DVD video so don’t export to 48 at the end).

I’m sure a better audio engineer here may be able to clarify if I’m wrong, but if suspect that while you’re recording, you hear the direct monitor out and you sound amazing and full quality. But you’ve only given Ardour leash to record at a far lower quality in those settings, so playback audio sounds microwaved.

I believe if you click “Window” the Audio/Midi setup settings are the first option on the drop down. Would you mind screenshoting your settings there? And better yet, would somebody please correct me.if I’m barking up the wrong tree entirely! Haha!

Thanks all

Hi,
hopefully I’ll able to help a bit. To begin I want to address that the difference between 48kHz and 44.1kHz is probably negligible in this case, so I wouldn’t worry about that (Edit: I missed the thing about the 1ms latency, that is a very very low latency and could cause issues. Try choosing a larger buffer size, 256 or higher just to check if that is the problem). Also the other comment said something about choosing the proper input and level, in that regard yeah, you should be connecting your guitar to the “Right” input with the switch on “guitar” mode, that would set the proper impedance to avoid the loss of low frequencies. An then gain the signal until you are hitting around -18db in average or near -10 on the peaks. Although these things should make no difference on the problem you are referring to.

Now about the issue on the difference between the live monitoring and playback I would incline to what @x42 said. That the difference is due to the different paths the audio is taking. If you want everything to sound exactly the same then what I would do is to first make sure that the “MON MIX” knob is set all the way towards “COMPUTER”. And then handle the monitoring inside Ardour. Which seems to be what you are doing…

The only thing I catch by looking at your settings is that the Disk I/O buffering is set to the max, I checked mine is at 10.0 and works well for mediumly large sessions. But I really don’t know the effect of changing that.

Other than that I don’t what it could be. Maybe try record the difference with your cellphone or something to see if that gives someone another idea of what it could be.

The owners manual says use the right channel for guitar (that means guitar or bass guitar, anything with coil pickups). The left channel line input is only 15 kOhms which is way too low for guitar to sound good. The right channel in guitar mode is 1 MOhm which is what you want for guitar.

That may not be all of it, but start there. You will have to play your guitar and watch the levels to see what level setting works best. You can just strum open strings pretty hard and adjust the level up or down until you are in the ballpark that diegoRad mentioned (doesn’t have to be exact, you just don’t want to go all the way up to 0 on the Ardour channel meters, audio interface distortion doesn’t sound nearly as cool as guitar amp distortion).

After that I would go into Ardour settings in Edit/Preferences/Signal Flow/Record monitoring handled by and set that to “audio hardware.” With that setting made, you use the “MON MIX” control on the interface to handle monitoring. When you are mixing, set the mix all the way to Computer, when you are recording you use that control to blend what is playing back already recorded on Ardour with what you are playing. By using the audio interface you don’t have to worry about what latency settings you are using, and can use higher latency setting in Ardour for less load on the computer and less likelihood of glitches while recording. I typically use 1024 samples with 3 periods for USB interfaces and don’t have any problems even on older or lower powered computers.

Alright people, basically what I ended up doing was to buy an active direct box, because as mentioned by all of you and my realization of when using the “mic” inputs, my guitar signal was so low, barely read by the audio interface, that i had to crank the gain. Now that i connect the Guitar to the Direct Box, to the Audio interface, I can use any of the two “mic” inputs directly, without having to adjust the gain at all, I have it all the way set to 0 on the audio interface. Basically, a direct input.

So the way I play/my idea of playing, is using ardour and vsts sounds to play and record, which is why i have the audio interface interface sample rate at 44.1khz and a sample rate of 49 samples, as its the fastest the audio interface will allow.

How true this is, I don’t know, I’m honestly not well informed nor understand all of this enough.

So my MON MIX knob is set all the way towards COMPUTER, and so is my line out is all the way to the highest, right, if that matters.