I cant record anything

Hi!, I’m an Ardour user, I never had any problem to work with, but now, I cannot hear, monitoring or record anything into my newest version of Ardour (2.8.4) in an intel macbook pro with snow leopard 10.6.2. I m using a Motu traveler interfase and I can see the meters recieving the signal, but Ardour doesnt do that, Ovbiusly, Every “route” of the signal is properly done, I mean, the mic 1 is in the ch 1 and in the input 1 of ardour routing to the master ch, and this is in the output 1 and 2, the record enable button is pressed and i couldnt hear anithing. Can someone helpme please?
Thanks a lot.
My best regards

I had all sorts of headaches trying to get Ardour and Jack for OSX to record after my Snow Leopard upgrade, and while I found quite some discussions on forums describing the same problems I had, found no solutions. Some things that worked for some people didn’t work for me, while others finished off threads without specifying what they had actually done do get it working

Anyway, with some help from my band’s bass player (a former Macintosh technician and all-round geek) I have now got it to work, and am posting this in the forums I searched to hopefully help others who are also frustrated.

I am using a 2.6GHz MacBook Pro almost 4 years old: the last revision of one of the early Intel models. For audio capture I have an Edirol FA-66, which uses CoreAudio on the Mac so needs no drivers. After a few initial headaches figuring out how to get them to work, I’d been happily using Ardour and Jack together since about October 2010, using whatever versions were current at that time, running in Leopard. Having set up the preferences in Jack Pilot, I never manually launched Jack. I would just launch Ardour, which started JackServer etc, and everything worked fine.

In May 2010 I upgraded to Snow Leopard, and a week later attempted to record some songs for a friend only to find that I couldn’t. The routing was correctly set up in JackPilot, the inputs were properly set in Ardour. JackPilot showed activity but no audio was getting into Ardour.

I updated Jack and Ardour, did all sort of restarts and disabling other software and repairing permissions, all to no avail. In the end I was only able to record using the Edirol as an analogue preamp, physically routing the audio from its outputs to the line-in on the Mac. Thus I could record two tracks at a time in Ardour: passable for this project but no good for anything more complex.

Because the Edirol still worked with CoreAudio (I could select it in the Sound Preference pane and get the system to use it) and Ardour still worked fine with analogue inputs, I concluded that jack was having a problem with digital audio only. I don’t know if this was a correct conclusion though.

Yesterday I had another project: mixing a multitrack recording from last November and recording new vocal tracks. In the interim I had installed whatever Snow Leopard upgrades had come out; and before starting I checked Ardour and Jack for updates, and installed the newest Ardour (2.8.10). My version of Jack (0.85) was still current. I was able to happily work with the prerecorded tracks, via the Edirol, but hit the same problem when trying to record new audio.

We used the Jack Uninstaller to uninstall Jack (funny that) and then installed a freshly downloaded version. Still no luck. We looked through the list of what was installed with Jack and found some components with quite old ‘Created’ dates. Uncertain, we used the Jack Uninstaller again and then manually deleted the dozen or so components that the Uninstaller didn’t uninstall. Then we did another fresh install. Still no luck.

We hit the forums again and tried all the suggestions we hadn’t tried yet, but still no luck. This time we noticed that JackRouter didn’t appear as an option in Audio-MIDI Set-Up or the Sound Preference Pane.

We then concluded that since Jack is known to generally work, and had been mostly working for us all this time, that the problem was somewhere in between the OS and Jack. On a hunch, we restarted the Mac holding the shift key down, which flushes all the system caches and starts the machine up in Safe Mode with all extensions disabled. Then, from the Safe Mode login screen, we did a normal restart. And that fixed it. Launching Jack adds it to the list of audio devices in the Sound Preference Pane, and we could record new vocal tracks in Ardour.

Now if anyone can suggest how to get my voice to sing in tune…


@darkdirk: thanks very much for posting this excellent, detailed description of your problem(s) and the solution.

Hi, I’m new to Ardour but your problem was my problem some days ago. I solved in this way:

  • I installed a jack gui called Jackpilot
  • every time I have to use Ardour, I open Jackpilot and I start it from the “start” button on the application panel, ONLY AFTER THIS I start Ardour

Let me know if it will work for you too.

Bye, :slight_smile:


First of all, Thank you, I was trying with your solution, but in this way, Ardour can only obtain signal from the built in microphone of my computer, and the Motu interface isn’t in the edit panel of the Inputs option, I mean, if I start the jack pilot application before i start ardour, I can record the signal, you’re right, but not from my motu interface.

I can import audio files and I can hear all of them with no problem trough my motu, but I couldn’t record anything. Please, could you tell me if can I do another thing about it please?..or simply, feel frustration…I need help …really. Thanks for your time.

ok I surrender, I’ll wait a new version to see if it works for me. Thanks anyway.

First of all, Thank you, I was trying with your solution, but in this way, Ardour can only obtain signal from the built in microphone of my computer, and the Motu interface isn't in the edit panel of the Inputs option, I mean, if I start the jack pilot application before i start ardour, I can record the signal, you're right, but not from my motu interface.

You need to open the Preferences dialog in JackPilot and change the device to read your MOTU. Otherwise it willuse the built in by default as everyone(Nearly) has that on OS X.

But in as far as the rest of your problem, you should get on IRC and see if someone can help you, it is much easier to troubleshoot and fix the issue there.


Thanks for your awnser, I can see in the preferences panel of Jack pilot the built in audio card selected, but the option to change this audio interface is disabled, I can’t do anything to change to my motu. Now I know where is the problem, thanks for that, the only thing that I need to know is: how to have the option enabled, do you know that? Thank you.

Stop the Jack Server(Hit STOP in JackPilot). Then open your preferences pane. You can’t change this value while Jack is running.

More info on using JackPilot with Ardour can be found here…


Hi Seablade, thanks for your reply, I did the changes that you said here, Now I can “see” the Motu interface in jackpilot, but, when I’m in Ardour, I can hear the signal from the microphone, but there is nothing into my track, It doesn’t register any signal in the meters, (with or without jackpilot runing), and I cannot record anything, I push the record button (after of the record enable button on my track, and the route of my signal trough the interface channel and the outputs) and when I pressed play button, anything happened, simply doesn’t record, I can feel that we are very close of the solution, but I need help. Any suggestion? Thanks Again
My best Regards

Did you check the Input to the track to make sure the Mic is actually routed to it?


I’m completely sure that the Input track is the same of the interface microphone input, and routed correctly into Ardour.

Hmm jump on IRC sometime and see if you can grab me or someone else there to help you there. This is turning into an issue that there is likely some small detail missing somewhere.


Thanks again, and sorry for the next stupid question, but, how can I jump on IRC? Thanks

@ferrerleon: http://ardour.org/support

Or just go to Help>Chat in Ardour :wink:


Hi Again “Mr” Seablade, After a lot of time and effort to obtain the solution to this problem, is solved, now I can record in my system with no problem at all. The problem was in Jack. Thanks anyway.
My best regards

Wait… since when am I a “Mr”

Eesh I sound like an old guy now;)

Glad it is solved at least.


Jaja, I’m just kidding I know that you are a young man, Please do not be offended, take it as an expression of respect :wink:

I wasn’t offended, just messing around;)