I can't assign MIDI controllers Ardour2

Maybe it is a problem with midi port jack or alsa sequencer but…
When I compile buy myself from the sources i can not assign MIDI control to buttons, fader , etc

sudo apt-get build-dep ardour
sudo scons install

When I press ctrl + Midle button nothing happens.
otherwise when I did in Karmic it worked OK

@monon: you need to make sure you’ve enabled “Generic MIDI” control in the Options -> Surfaces menu.

@ paul:

Well, I just can’t figure it out, in this release it just defaults the Generic MIDI to “disabled” mode. A very few times I was able to reopen a session with the bindings saved, closed and reopened the session and no longer was Generic MIDI enabled, when re-enabling, the bindings were lost making me re-assign them again. Always checked that midi connections were connected in qjackctl, even tried before opening Ardour, I would launch Ardour, then at the starting prompt window I would switch to qjackctl and connect the M-Audio Oxygen to Ardour control, then load the session and would still fail to have MIDI enabled.

When I trace the input in terminal there is no problems there, shows me all MIDI activity.

Also I have my Oxygen connected via MIDI to Fast Track Pro, so I also tried instead of connecting Oxygen to Ardour I bridged it with Fast Track Pro, so Fast Track would send the MIDI messages to ardour and had same issues, sometimes (very few) it did remember the bindings but mostly would reset, thinking if maybe could be something to do with M-Audio MIDI, both devices are M-Audio.

I check ~.ardour2/ardour.rc and it defaults the MIDI settings right there

The Mute bug still persists also, have to open ~.ardour2/ardour.rc to change the values, these values don’t change like the MIDI settings, they do remain as edited.

One last thing, I mostly get the log window when reopening sessions, the main message is this:

[ERROR]: control protocol XML node has no name property. Ignored.
[INFO]: Loading session /home/joe/Desktop/test using snapshot test (1)
Loading history from ‘/home/joe/Desktop/test/test.history’.

I’m not sure if this has to do with the MIDI bug I’m having, since it happens quite often also.

I’ll wait for further instructions from you, I just couldn’t figure it at all, deleted my ~.ardour2 folder many times and nothing…

So if you have any ideas just let me know, I do want to see if anyone else is having this particular issue.

Hi paul:
I am having similar problem with 2.8.8.
I reported a bug for SVN a few weeks ago: http://tracker.ardour.org/view.php?id=3139
When I set up my midi bindings and enable midi under options (Generic Midi), it’s defaulting to disabled, mostly with all sessions I save and always with new sessions.

I’, going to sit down and figure out what could be going on and if I figure something out I’ll let you know.


EDIT: Creating template doesn’t seem to work either, Midi becomes disabled also.

I’ve reached to work the MIDI assignament opening a session selecting Generic MIDI from surfaces menu and closing and reopening it.
But in previous releases I didnt must to do that.

Hmmm strange, that’s how I used to set it up before 2.8.8, it never worked (or assigned actually) from starting a new session, I thought that’s how it worked, but with 2.8.8 it just looses it. I’m compiling 2.8.9 @ the moment, will be testing and post results.

Well, I finally got it saving the bindings, quite tediously though… here are steps so MIDI bindings are not forgotten and MIDI doesn’t deactivate:

1.- Create new session, add track, save and close.

2.- Reopen session, this is where I get the log window with “[ERROR]: control protocol XML node has no name property. Ignored.” message, and disables MIDI, so I re-enable MIDI under options and I laso check bindings assigned by user. Save and close.

3.- Reopen and assign bindings, to track levels. Save and close.

4.- Reopen move knobs in Midi device and it finally responds. Now when I add a new track(s) I can successfully assign new bindings without all this save-close-reopen stuff It’s the only way I have successfully made it work. I reopen the session a few times and bindings still saved. I can live with that, as long as it’s part of setting up a session, it takes longer for an artist to stretch canvas on a frame before painting.

I had to create a qjackctl Patch definition to automatically connect Fast Trac Pro to Ardour.

Will be testing with templates soon.

Anyone else with a similar issue?

UPDATE: Templates save perfectly from a session created with steps above. All MIDI bindings are saved and Generic MIDI under options always enabled. :slight_smile:

Ok finally i’ve found the problem…
it was a2jmidi. I was bridging hardware port with it ( option -e) and it wants just to bridge software ports.

Now it works OK