I cannot change music synth instrument

I’m new to ardour and to computer music. I’ve used a midi file previously recorded. I added a MIDI track and put my midi file 2 times in the track. Pressing the space bar, it played with synth piano. But when i change the instrument in the general synth plugin to a distortion guitar and then i loop the track, it plays once with the guitar but when it loops back to start, the instrument changes back to the piano. It’s pretty annoying. The same when i usevthe Helm plugin, i change some knobs and when it loops back, the knobs reverse to their default state. Nevertheless it works perfectly with other plugins like amsynth (i haven’t checked them all). Am i doing something wrong or is there a bug in Ardour? I didn’t know in which category i should post this, i hope i am right.

There is likely a “Patch/Program” change in the MIDI data itself. Playing the MIDI does automatically select the instrument.

Do you seem some patch-changes (small boxes at the bottom) in the MIDI region?

Example here: “prg 3 bank 129”:

If so, you have two options: Remove that Patch-change and manually select an instrument patch,
or modify the patch-change it to be the instrument you want.

see also http://manual.ardour.org/working-with-midi/patch-change/

1 Like

Thanks ! There was the problem, i didn’t see those little boxes. Is there a preferences option where i can prevent them from spawning when i import a midi file or do i have to select no instrument each time i import a file?
Oh ! And also, how do i mark a topic as solved ?

No. Those “boxes” are MIDI messages just like Note-events or Control-Changes.

I suppose a future version could have an option in the import-dialog (not preferences) to filter out those Patch-Change and Bank-Change (CC) MIDI-events, but it’s currently not possible.