I can run Jack as root but not as user , why ?

I tried to find answer in previous topics however , I couldn’t . When I start Jack as root is ok but Ardour shows message : Ardour Could not start Jack

If I want to start Jack as user then Jack Could not connect to JACK server as client

Can anyone help me ?

many thanks

would you be running Ubuntu per chance?
Most likely your system is set up to start jack in realtime mode without your system being configured to allow access to resources needed for realtime mode (it seems like I am answering this question somewhere for somebody at least twice a week for the last few months)…

your options

  1. turn off realtime in Jack Control.
  2. add a group to your system for audio users (create a new group called audio if there isn’t one), Add yourself to that group. edit /etc/security/limits.conf and add lines similar to the following.

@audio - rtprio 65
@audio - nice -10
@audio - memlock 40000

at the end of this file. save it, log out and then log in again.

In a fact I am new user of Ubuntu , I was trying to use linux OS couple times in a past , my knowledge is pretty poor however , I am learning at the moment.

Thanks for the answer the problem has been solved but I did it in other way.

in /etc/security/limits.conf I changed @audio to @user_name , it started to work.

Jacks is starting so , but now I have next problem about configuration , when Jack starts sound disappeare , I suppose it is because I have to set up in and out , just don’t know how , I can see is not as much articles about in internet.

anyway , you helped me , thank You Danni

uputupu, once jackd is on and runs fine, non-“jackified” applications will not be able to use the audio device jack has a grip on.

So if you expect your window manager/ system sounds to still be ehard when jackd has started, you will have a bit of a problem.

Is this your current issue ?

Yes , it is.

then you need to know which sound server your WM is using:

  • pulseaudio (recent linux distros) ?
  • older ones like esd (GNOME) or artsd (KDE) ?
  • plain ALSA (no sound server on top) ?

pulseaudio can make room for jack, there are numerous discussion threads and howtos in e.g. ubuntuforums.org

esd and artsd have jack plugins available from the WM configuration. Not sure how efficient they are though.

apps that use the ALSA layer directly are problematic.

One efficient way to deal with all this is:

  • keep the onboard audio chip on hw:0 and let the WM use this one
  • get jack to run on a second device (PCI, firewire or USB) on hw:1 or ffado for firewire.

This way, you will not have overlaps between your WM and jack. And in fact, it can turn out to be a very good thing if you are serious about your audio work with jack.

Thanks thorgal , I don’t know how to identify which device WM is using. As I wrote I am totally green.

If I have correctly understood , in third option I need to have two devices ?

I use ( for the time being ) integrated audio chip on motherboard which is working fine and it is only one device installed.

Probably I am a bit lost as I write questions about things which I am not able to understand yet. What the main target is ( at least for now ) , I need to use ‘line in’ from my integrated device on board to record some stuff. Simply I want to check how to use Ardour.


if you just want to check how ardour works, I suggest you ignore the fact that your WM cannot output sound due to jackd having exclusive access to the audio device.

As soon as you turn jackd off, your WM will be able to use your sound device alright.
A little price to pay to get jackd + ardour doing a great job :slight_smile:

For identifying which device your WM is using, as long as you have only one (onboard chip), then you know it’s gonna be that one :wink:

If you like ardour and jack (and for that, you do need to test what they can do) and would like to dive more into music production, you will quickly conclude that a dedicated device (not onboard) will be worth the investment

I forgot about the sound server. Which version of ubuntu are you using ?

If it’s a recent one, chances are you are using pulseaudio. You can check that by investigating which processes are running:

open a terminal and type

pgrep -l pulse

if you see some output, then it is running.