Hydrogen samples in ardour midi tracks

hi

I am in the process to move my workflow from using hydrogen drumkits directly into Ardour’s midi tracks.
Thanks to the help of plugins like LSP sampler I manage to load the drumkits and map the samples as midi notes into midi tracks in Ardour.
However the resulting sounds of the samples are “cut off” I can’t seem to gettting the full sound no matter if I max the velocity and all the parameters in the track.
I made sure to give the drum samples all of the tail within the plugin and they work fine when I test the sound however when I playback the sound I get a kind of “cut off” version of it.

The problem seems to be consistent using different drumkits and also using other sampler plugins.

Do you have any idea about where the problem could be?

Good day,

maybe this link will help:
http://hydrogen-music.org/doc/

I don’t know much about MIDI, so this is a shot in the dark. Did you set the note mode to “Percussive”? The default is “Sustained”, which I think would cause the note to stop as soon as its note duration ends rather than when the sample ends. Changes to Note Mode can be made by right-clicking on the MIDI track in Ardour’s editor view.

The MIDI tracks are indeed already set to percussive. Forgot to mention that this is Ardour 6.9.

The default is “Sustained”, which I think would cause the note to stop as soon as its note duration ends rather than when the sample ends. Changes to Note Mode can be made by right-clicking on the MIDI track in Ardour’s editor view.

I think the issue comes from the live processing Hydrogen does on drumkits, because in drumkits each sample is applied an envelope.
I never could get Hydrogen drumkit samples working directly in a generic sampler.
I suggest you use the DrMr plugin, which is made to play Hydrogen drumkits (yes I know it’s not maintained…) : GitHub - nicklan/drmr: An LV2 sampler plugin that (currently) plays hydrogen drum kits

Regards

Thanks.
Interesting I will take a look and try. FYI I am going to be away from audio workstation for next 10 days.

I have tried this but I have got similar result (using Ardour 6.9 and 7.1 as well) From the plugin itself I get a full sound but when I draw the midi I clearly hear a cut and not the full body played back.
I have tested with both percussive and note modes but I get the same results no matter the velocity I set or if I increase the notes length.
Now what puzzles me even more is that if I record the midi part with the keyboard instead I get the expected full sound when I play it back.
How strange
I have also tried geonkick and I see the same behaviour.
I don’t think the problem is isolated with hydrogen drumkits at this point. I have not tried sfz drums samples yet…

If I remember correctly the LSP sample player can also load Hydrogen kits.

I also recently migrated from Hydrogen to LSP Samplers, I remember it worked fine when I loaded a drumkit. I just tried it, using the Hydrogen’s Black Pearl kit. I set just the Floor Tom (it has a long tail) to a new midi note and it plays with no problem whether with drawn midi or triggered with the virtual keyboard.

Same Ardour version.

Thanks for the feedback. I am going to start with abrand new project from scratch as test. There must something I did wrong or some misconfiguration
Can I ask what version of LSP samplers are you using?..although I don’t think my problem is related to LSP at this point

1 Like

LSP Package version 1.2.3. Been away for a few days. Are you sorted out yet?