Huge latency jump

Suddenly, without me changing anything, my i/o latency jumped from 25ms to 65. Running Ardour 6.0 with Presonus 96, 44.1k 512 block size.
Windows update 2 days ago possible culprit?
I can’t do anything with 65ms of delay.

Have you tried changing the settings using PreSonus’ “Universal Control” panel, or the ASIO control panel?

In some cases those settings are persistent, and Ardour’s audio-engine setup cannot overrule them.

Maybe also re-install the PreSonus ASIO driver. perhaps the Windows update has disabled that and you’re now using the Microsoft’s generic USB driver?

I have updated the Presonus drivers via their website and tried many different settings. All result in exactly the same i/o number. I don’t see how to get to any asio settings directly but I will poke around when I get back to the studio.
I am going to download audacity and try to rule out Ardour…or not.
I really hate this random kind of issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.