How to use multiple pluging per track?

Hi all…
Just trying to get my head around Ardour (using ver 4) and have got stuck with this one.
Cant seem to use more than one plugin per track… Get an error message when I try to add a second plugin about inputs and outputs, cant I stack multiple effects on each track?


A few things:

  1. Please update to a more recent version of Ardour, that is vastly out of date.
  2. You can absolutely use multiple plugins, if you read the error though it likely says something about an input and output mismatch. This is something that was made much easier to address in Ardour v5 through the use of pin connections. It is still possible to address in A4, and the number of plugins has nothing to do with it, but rather the number of inputs and outputs expected by a plugin at a given point, so you have to make sure the number of audio signals match the number of inputs and outputs expected by the plugins through the use of splitters, mixers, etc. or just use different plugins that can handle the appropriate number on inputs and outputs.

But as I said, upgrade to A5, that handles this much better and is far less buggy.


Thanks for the response seablade… Going to stick with the free version for a while to begin with, not entirely convinced that Ardour will serve my needs yet and I keep running into brick walls like this one… So far, I am guessing I have spent around 30 minutes doing music and about 50 hours trying to get around problems or learning how to do the basics… Unless I can turn those numbers upside down I will be moving on…
Could you be a bit more detailed in how I sort this problem please? Have seen a few other posts around the net with the same issue but the solutions offered assume a working knowledge of the software which none of us appear to have and we all seem to be left scratching our collective heads… When I try and add a second plugin I get;

You attempted to add the the plugin “Calf Fluidsynth” in slot 1.
This plugin has;
1 Midi input
0 audio outputs

But at the insertion point, there are;
1 Midi channel
2 audio channels
Ardour is unable to insert this plugin here.

Is there a simple fix…?

V5 will automatically create the connections needed when you attach a plugin with different numbers of inputs or outputs, as Seablade has already said. That is the “simple fix” you are looking for.
The restricted free download of Ardour 5 will show you whether this fixes the problem you are seeing.

You can even buy the unrestricted version for just $1.
Of course, if you subsequently decide that your $1 was a little mean and Ardour is worth more than that, you can still take out a subscription or donate what you think it’s worth… :slight_smile:

Thanks anahata…
Sort of ‘buy before you try’ principle…? Not wanting to turn this into an issue about me buying the latest version, if I can get this to work and make some music then I will be more than happy to pay for the latest version. If I cant make it work for me then no, it will not be worth one cent to me… Have put in a lot of time and got nothing but frustration out of it so far…
Is no way to sort this in ver 4…?

The most likely reason for the message that Ardour is giving you is that you’re trying to add a second synth plugin to a MIDI track that already contains a synth. What do you expect to happen in that case?

Hi Colinf
Sorry, you are quite right, except the exact same result happens when I try to add a reverb unit, compressor or any other plugin… I only tried to add the calf synth in order to call up the error text so I could post it here, but the same error happens every time I try to add any other plugin when one is already there…
Have spent some time trying to find what an ‘insertion point’ is but am getting nowhere… seablades statement of ‘make sure the number of audio signals match the number of inputs and outputs expected by the plugins through the use of splitters, mixers, etc’ is certainly suggestive that a solution exists, but I have no idea what that means nor do any searches on the net reveal anything useful…
Would have thought this was fairly straightforward to sort when I first posted the problem, am none the wiser yet though…

Ok. guys… Thanks for your time but am now going to walk away and give up with Ardour… Have now spent 60 hours trying to make it work and have made zero music during that time…
Have found another piece of software that I seem to get on with right out of the box so am going to go with that instead…
Have fun and thanks again…

The ‘insertion point’ is the place in the processor box where you’re trying to add the plugin (see If you get a message similar to the one you quoted, it means that the plugin you’re tryng to add isn’t compatible with the signal(s) at that point. The exact text of the error will tell you exactly what signals exist at the insertion point, and what the plugin requires.

It may be as simple as trying to add a stereo plugin where there is only a mono signal, or it could be something else: it depends on the number of inputs & outputs of the channel strip, or the plugins before or after the insertion point. If you’re trying to add a stereo plugin to a mono channel in Ardour 4, you’ll have to manually insert a mono-to-stereo splitter plugin first.

Ardour 5.12 does this automatically, as well as fixing many many bugs, adding support for in-line LV2 plugin displays, plugin pin connections, and more, so I’ll also agree with all the other posters here that this works so much better in the latest version that you’re probably wasting your time trying with Ardour 4 at this stage, and should really upgrade.

Sort of 'buy before you try' principle..?

Or download the free version and try before you try works as well.

You attempted to add the the plugin "Calf Fluidsynth" in slot 1. ...

As colin mentioned this particular thing is tricky, it is expecting a plugin that can take both a single MIDI input and two audio inputs, very few plugins probably exist that do this, so for this particular issue probably not. IF you are still around, how did you create this exact issue? I wonder if it was a specific synth plugin.

As others said the exact text of the error gives away what the issue, in v4 you had to fix these manually, v5 improved this tremendously (Though you still run across it in certain combinations) with the pin connections. In v4 you could run across it by inserting a mono plugin on a stereo track or vice versa, could be fixed by using a splitter or mixer plugin for instance to change the number of audio streams to match as needed.


What is the version of the calf plugin? The error message shown indicated that the plugin was reporting 1 MIDI input, and 0 audio outputs. That does not seem like a very useful synth plugin if it accepts MIDI input but has no output. I don’t recall Ardour 4 having major problems reading plugin parameters, so I would suspect the calf plugin as more likely the source of the problem.
And as others have pointed out, Ardour 4 was released more than 3 years ago, use the free demo of Ardour 5.12 instead.