How to use an M-AUDIO card under Linux...


Everybody seem to agree that a 1010 or 1010LT is easily setup in Linux, but having used it under Windows, I am a bit doubtful about how the M-AUDIO console is supposed to work in Linux. In other words, M-AUDIO has a dedicated application which controls the card input and output volume, balance, etc, for all the available ins and outs.

Since I want to be able to use both the integrated soundcard with ALSA (for any type of crappy multimedia content) and the 1010LT wiht Jack, how can I control these features under Linux?

Hey, Thorgal!

I knew this could be done, because you suggested it yourself, so thanks again!

I guess I am still a bit confused, since I am talking about something I have not done yet. I will keep in mind this advice, and if I can´t make it work, I will try and get further help from you, if that´s Ok?

Thanks again

no prob, just shoot :slight_smile:


make sure ALSA boots so that the onboard chip is hw:0 and the delta is hw:1
it’s not always systematic but you can fix it by modifying /etc/modprobe.d/alsa-base or something like that on debian based systems (not in front of my DAW at the moment)

then, you configure jack to use hw:1 (the delta). In qjackctl, you can choose which h/w to use in the setup window.

The mixer app you should use for the delta is envy24control, part of the alsa-tools-gui package.

The mixer app for your onboard can be gnome-alsa-mixer or kmix (GUI for the generic alsamixer).

I don’t have a delta card but an RME card at hw:1 and that’s what I do. I connected some cheap speakers to my onboard and get all the bad stuff outputted there (flashplugin mainly). Jackd is exclusively using hw:1 (my RME card) which I use for the real thing :slight_smile:

So my system is completely decoupled in terms of sound cards and that’s been so far working excellentissimo :slight_smile:

Hey, Thorgal,

Got my LT today, but no luck so far.

It was correctly (I think) picked up by my Ubuntu Intrepid PC, but I can’t see any hw:1 entries when running qjackctl.

Just to give you some background of what I did:

aplay -l returns:

administrator@GuitarDreams:~$ aplay -l
**** Lista de PLAYBACK Dispositivos Hardware ****
tarjeta 0: Intel [HDA Intel], dispositivo 0: AD198x Analog [AD198x Analog]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 0: Intel [HDA Intel], dispositivo 1: AD198x Digital [AD198x Digital]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0
tarjeta 1: M1010LT [M Audio Delta 1010LT], dispositivo 0: ICE1712 multi [ICE1712 multi]
Subdispositivos: 1/1
Subdispositivo #0: subdevice #0

So I added the following to /etc/modprobe.d/alsa-base:

alias snd-card-0 snd_hda_intel
options snd_hda_intel index=0
alias snd-card-1 snd_M1010LT
options snd_M1010LT index=1

Rebooted, but nothing, options in qjackctl:


Any ideas?

Hi again,

After doing some “googleing”, I can tell that what I added to alsa-base is incorrect. However, I don’t see any clear direction as to how I should tweak it. I modified it with this:

options snd-card-0 index=0
options snd-card-1 index=1

Which made more sense to me, but still no results.

Any help appreciated!!

Nah, forget about it…

So damn stupid, I just found the button and it’s all in there…!!!