How to slow down the exporting process

I am using jconv for convolutoin reverb by using sends and inserts within Ardour. After a my last recording session I figured out that the exported results are containing dropouts even there was NO xrun told by jack.
At the end I found out that jconv is the reason for that because session without jconv do not have this issue. When i just record the master bus output to a new track, the result is fine - even with jconv included. If I am using the export functionality of Ardour, the results contains dropouts.
Therefore I guess this could have been caused by the dramatically increased speed while exporting a session where jconv seems to have problems with. I would like to try to slowdown the export as a workaroud but I do not know if this is possible. Could you perhaps help here?


Thats easy:

Create a new stereo track, and route the master outputs directly to it. Enable record on the new stereo track only, and just rec&play your song. Make sure the newly created track doesn’t output to the master bus. This will “export” your project to a stereo track, at normal play speed. Then export like normal, but only enable the new stereo track while exporting.
This should solve your problem.
You could also use the same technique in another way:
Route the jconv output to a newly created track, rec&play it. If you’re done playing, turn off jconv and then export as normal. Your new track will be the reverb.

I would use the second way, because you can adjust the reverb level at a later time.

Hi Roaldz,
I already used your first solution but I consider this as a workaround. I am thinking about slidly decreaseing the export functionality. Maybe this is not possible. I did not have this issue before in the past. The only difference is that i am using a dual core machine and in the past it was a single core. Therefore I guess that the root cause of this issue could be the dual core or maybe the irqbalance daemon? I will check this. Did you make a similar observation at your side?
It really would be more comfortable to be able to use the usual export function.


I found a temporary fix…
I know this is old, but I stumbled upon your post because I was looking for a solution for the same problem. Try running jack without the RT option when exporting. It seems to be working for me.
Didn’t work perfectly… still some artifacts. This is frustrating.

The issue is a known problem in jconv, it does not handle Jack’s freewheel mode very well. For right now your only option is to bounce the track as was described above.


Funny, I just saw that the new release of jconv actually warns you when entering freewheeling mode! Oh well, bouncing the tracks the old fashion way is not too bad and the reverb is well worth it.