How to restart alsa?

I have a hunch that all i need to do is restart alsa from some type of sysctrl to solve my problem.
How to do that?

Problem:
I have latest avlinux from about 2 weeks ago.
I have noticed that I have to boot with the usb Interface plugged in in order to be “seen” by the system. (I use the default config of avlinux).
I think i might be able to restart the alsa from the command line to fix?

Try the following:
sudo alsa force-reload

knife

This is very unusual. USB allows for hotplugging.
When you re-plug the device, can you check if there are any system messages

sudo dmesg

is the USB device present (but just recognized by ALSA):

lsusb

Have you tried a different USB port?

I appreciate your answers… after my exam, I can look into this some more.
It might be unique to the zoom h6 which is a little touchy.

It says there is no such command for alsa

Hi, did you tried
“sudo alsa --help” ?

There is no such tool, at least none that comes from upstream.

If you’re thinking of either System-V (/etc/init.d/alsa or
/etc/init.d/alsa-utils) or systemd’s alsa service, those scripts only save/restore mixer-levels. They do not reload kernel modules, but simply call alsactl under the hood.

2 Likes

I did a test to plug in and unplug. It seemed to work. I suspect it could have been the battery levels for the zoom h6 at that time. Batteries are required to operate on some computers. My computer is one of those. I also need to use the right usb port.

If it happens to still hang after hotplugging you might try unplugging and removing the usb-audio module via

sudo rmmod snd_usb_audio

and plugging in again. The module will be reloaded automatically as soon as your device is detected. Usually this should not be required in any way but I remember having some very quirky USB card that needed to be reinitialized like that from time to time. Makes a lot more sense than “restarting ALSA” which doesn’t really work because ALSA is just the kernel modules and a couple of userland utilities - not a service one could restart.

I’m convinced it is my low quality computer and let it be a warning not to get a lenovo amd computer (probably any amd computer)… but it is probably a bad bios that lenovo uses.

The good news, is I started to explore Windows based DAW, and that experience was not fun. So kudos to the ardour team for creating software I believe is my only option :grinning:

Historically the Lenovo laptops came from the IBM laptop group (over 10 years ago now), and at least in the past were high quality and well supported in Linux.

AMD machines are also usually trouble free due to the long history of open source support for the AMD graphics adapters.

So in my experience out of your combination of Lenovo laptop, AMD processor/GPU, and Zoom interface, Lenovo and AMD are usually trouble free, but Zoom interfaces are an unknown.
Unfortunately based on my experience of industry trends the last few years, it is possible that Lenovo quality has decreased since I last used a new Lenovo laptop, but I would at least start your investigation with verifying that the Zoom actually implements USB audio class properly.

It seems like you already found that the Zoom device cannot run on only bus power, but requires additional power to operate properly. Does it have an external power input, or do you have to remove the battery and charge it separately before using the interface?

Well, as a monk and I’m stuck with what people give me. Someone asked me to give away my previous Acer laptop and receive a new one. It is nearly the same class of machine, but because 3 years newer, it was a little bit faster. I too thought Lenovo would be very compatible since they ship with ubuntu or say they do on omgubuntu. I bet they don’t ship with the amd chip. The built in graphics driver is not part of the kernel and it needs to be installed with a ppa and it rebuilds things and fails. Do get what I’m trying to say? Then vivaldi crashes… due to driver issues. Android dev with the emulator is not easy either. I finally switched to windows and it is more stable… I had my first run-in with a security alert from Google. It might have been a vpn use with the vivaldi email client, but I’m not sure. This is not good considering I make free nc software with about 3500 downloads (total) and I also have a website that gets 40k plus visits per year.

In any case. I trust it is a machine problem. I appreciate your help.
I also have the cheaper Lenovo version. The Thinkpad brand might be better. However, I installed ubuntu on a teacher’s old thinkpad and it was not working out well. I lost a linux convert on this as well. Even I myself switched to Windoz. I also don’t have grub as default and switch the bootloader on boot when I need to go to avlinux.

Device name LAPTOP-D0KNF8Q8
Processor AMD Ryzen 5 5500U with Radeon Graphics 2.10 GHz
Installed RAM 8.00 GB (5.86 GB usable)
System type 64-bit operating system, x64-based processor

I do not understand why that is the case, the Radeon driver has been open source since 2007. I have used exclusively ATI/AMD graphics cards for over 15 years specifically because I never needed to deal with customizing the drivers, I just install the latest kernel update and never think about graphics drivers.
Perhaps this is one of those cases where Ubuntu takes upstream software and makes it worse.
Or perhaps could be solved with a configuration change to use the drivers from the kernel source tree. I do not use Ubuntu so cannot help with the specifics, an Ubuntu specific forum would be more likely to have useful assistance.

Obviously, my screen works without such installs. But there is a problem with chromium based browsers. After partially installing a broken GPU (which is downloadable), the screen does look better, but it is still unstable. Right now, i have a boot with av linux with nothing added and I pretty much only use it for ardour related stuff.