How to properly load VST3 on Linux?

Hi everyone!!.. I believe, the announcement of 6.4 release is a big step forward for Linux users, and I’m very happy about that… But still don’t understand how is possible to support vst3 for our platform.

Using linvst3 bridge I have to convert vst files in .so files while scanning vst3’s Ardour is looking for .vst3??.. On Ardour the only way I can load vst3 plugins is adding its path file in VST 2.x section in preferences. But that’s not clean at all…

Somebody experiencing the same? Or maybe I’m doing something wrong…

Cheers

In the preferences, under VST3 there is the option ‘additional VST3 path’ - you can add more locations by clicking the ‘Edit’ button. If you are using Linux, then, as with Linux VST2 plug-ins, you will need VST3 plug-ins which have been compiled for Linux.

Thanks… Yes! i did that but didn’t work… that’s why have tried loading .so vst3 from vst2 and worked apparently…
EDIT: I have mentioned that I use linvst bridge in order to work with no native linux vsts

That won’t have any effect for VST3 plugins. Are you certain that the plugin you specify is a VST3?

Ardour looks for VST3s in the path as specified by Steinberg in the VST3 Spec:


(you can only add additional paths for edge-cases e.g. flatpak bundled versions)

VST3 plugins are not plain *.so files. They come in a plugin bundle.

On Linux, a VST 3 plug-in is organized as a bundle like package format, its file extension is *".vst3"

(from https://steinbergmedia.github.io/vst3_doc/vstinterfaces/vst3loc.html#linuxformat)

It is however possible to create a .so that works a both VST2 and VST3, but for the latter to be recognized it has to be in a .vst3 bundle.

Instead of just a single .so file, a VST3 plug-in (on Linux) is really a folder called plugin-name.vst3 (where plugin-name refers to the plugin) inside are the components that make up the ‘plug-in’ including some resources, and a .so file containing the executable code). I think the same is now true on Windows, though it used to be just a .dll renamed to .vst3

Thank you guys for your replays…

That means my solution is the only one in this cases? I believe there are a lot more people using windows vsts on linux with bridges like linvst…

Its great to have more linux users, but the real solution is to get more plug-ins ported to Linux. This is happening gradually, there are more developers providing Linux versions, and hopefully that will improve with hosts like Ardour now supporting VST3, but ultimately Windows is the best OS to run Windows software on, otherwise you will always have to rely on slightly clunky - and sometimes unreliable - workarounds

2 Likes

Totally agree… however I personally use wine-staging and linvst and they do an excellent work. Hopefully it will be not necessary! As linux users we can prove to plugin vendors that their products can work on linux and insist on asking for native support…

Sorry for my english… I’m trying hard to explain myself! :slight_smile:

Maybe I should start a new thread, but VST3 do not show up in Ardour 6.5 on Linux 64 installed with the “official” binary in /opt/.
I did add the Path to the VST3 (works in Carla by the way) but no VST3 in Ardour 6.5.
In the logs I only see that they are Blacklisted from VST2 (if I add their path to VST2. I tried many things …)
I tried with Odin2, Speedrum lite, Surge and Stochas.
Any idea is welcome

There should be no need to do that. VST3 are supposed to be in locations as specified by Steinberg:

Surge.vst3, sfizz.vst3, u-he VST3s, ACM/OverToneDSP are all known to work, among many others.

quick test, do the following files exist?

ls ~/.vst3/Surge.vst3
ls ~/.vst3/Surge.vst3/Contents/x86_64-linux/Surge.so

Sorry, I mean I added “/usr/lib64/vst3” to the VST3 search path in Ardour.

ll /usr/lib64/vst3
total 0
drwxr-xr-x. 3 bruno2 users 22 21 oct.  11:59 Odin2.vst3
drwxrwx---. 3 bruno2 users 22 18 août  22:22 speedrum_lite.vst3
drwxr-xr-x. 3 root   root  22 23 nov.  22:22 Surge.vst3
ll Surge.vst3/Contents/x86_64-linux
total 6,1M
-rwxr-xr-x. 1 root root 6,1M 23 nov.  22:22 Surge.so

Ardour does not search there. Please see the link to the VST3 spec linked above.

Also note that the architecture is part of the plugin bundle:

A Plugin.vst3 can contains multiple archs x86_64-linux i386-linux etc. So placing it in an arch-specific folder like lib64 makes no sense.

1 Like

OK, then the bug is that Ardour does not take into account the “Additional VST3 Path” in Preference/Plugins/VST

and (one of) the workaround is to make a symlink ln -s /usr/lib64/vst3 .vst3

I will not try to make sense of the tooo long history of Linux filesystem Hierarchy :slight_smile:

Thanks a lot !!! It does work !

I made more tests and submitted a bug https://tracker.ardour.org/view.php?id=8496